Electrical Problem related to clutch noises. - JeepForum.com
 
LinkBack Thread Tools
post #1 of 3 Old 06-09-2021, 05:18 PM Thread Starter
Rabin
Registered User
 
Join Date: Jun 2021
Posts: 1
Electrical Problem related to clutch noises.

Hello all,

A few weeks ago I picked up a 2003 TJ, 4.0, 5 Speed. Everything worked fine at 1st and out of the blue I started experiencing an odd issue where certain electrical components stopped working (windshield wipers, blinkers, AC, Radio just off hand) at the same time my clutch starting making a horrible grinding noise when fully depressed. The problem is sporadic, sometimes it cranks up fine with no electrical problems and no clutch noise, other times I have said issues, but it's always both issues when it happens. Is this just an extremely odd coincidence or is there some relation between those two problems?

Thanks!

Rabin is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 06-10-2021, 06:51 AM
53flattie
Registered User
 
53flattie's Avatar
1936 CJ2A 
 
Join Date: Aug 2012
Location: Easley
Posts: 317
The only electrical component in the clutch system is the “neutral safety switch” which requires the clutch to be depressed in order for the engine to start. But I can’t imagine how that would lead to the other issues you mentioned.

Look under the dash, where the clutch rod goes through the firewall, and make sure there are no wires being pinched by the clutch pedal movement. If not, I would say the two problems are not related.


Sent from my iPhone using Tapatalk
53flattie is offline  
post #3 of 3 Old 06-11-2021, 02:02 PM
Jonny Jeep
Web Wheeler
 
Jonny Jeep's Avatar
1997 TJ Wrangler 
 
Join Date: Feb 2007
Location: Manchester
Posts: 6,764
Maybe it's temp related if they only happen at the same time.


Radio, wipers and turn signals are on the same contacts in the ignition switch so that is #1 suspect for the electrical problem.


The clutch pedal links to the master cylinder using a plastic bushing. The bushing may be worn, or broken. They are a few dollars for a replacement. I need to replace mine (again) as I'm getting noise from my pedal, but not all the time. I've looked already and know my bushing is worn.
Jonny Jeep is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome