No turn signals - JeepForum.com
 
LinkBack Thread Tools
post #1 of 8 Old 12-02-2003, 05:32 PM Thread Starter
twmattox
Registered User
 
Join Date: Mar 2002
Location: Indianapolis
Posts: 1,333
No turn signals

I don't have turn signals anymore. My flashers (hazzards) work and all the lights (inside and out) blink, but when I try to use the turnsignals, nothing...all the lights remain dark. I assume it is a problem in the column. Anyone know a way I can test before I take it apart? I was thinking of using my multimeter on the harness, but don't know what to hook up to...

twmattox is offline  
Sponsored Links
Advertisement
 
post #2 of 8 Old 12-02-2003, 07:07 PM
bods7
Registered User
1983 CJ7 
 
Join Date: Oct 2003
Posts: 190
Just to cover all the bases. All the lights do work right. Do they work when the hazards are on right. If these statement are both true then you have either crossed wires or the turn signal switch itself. Multimeter is the way to go that should tell you if you getting full voltage or not. Good luck.
Ryan
bods7 is offline  
post #3 of 8 Old 12-02-2003, 07:23 PM
aviator
 
Join Date: Mar 2003
Posts: 183
It could also be the turn signal relay. I would start there first if all the lights are working. The relay is cheap and easily installed.

The relay is the large round, leftmost "doohickie" at the top of the fuse box. There should be two of them. One is probably metal the other is probably plastic. the left one is the plastic the right one is the metal one. Try switching them and seeing if the blinkers start working and the hazards stop. If that's what happens, you have a bad relay.
aviator is offline  
 
post #4 of 8 Old 12-02-2003, 09:48 PM
Jwhit
 
Join Date: Jun 2002
Posts: 58
those relays you speak of are not actually relays. They are the flasher itself. they have a capacitor that charges and discarges to make the flashers go on and off. The flasher responsible for the turn signals is metal.. at least it is on my jeep and it is just dangling from wires that come out of the main wiring line that goes over the steering column. basically replace the round metal things and you should be fine. If not uhhh good luck figuring it out!
Jwhit is offline  
post #5 of 8 Old 12-03-2003, 08:42 AM Thread Starter
twmattox
Registered User
 
Join Date: Mar 2002
Location: Indianapolis
Posts: 1,333
Additional Info

I just found out today that when the turnsignal is on, that sides brake light doesn't work.

Also, I don't have two flashers, just one. I have replaced it a number of times with the same result...

Where do I hook the multimeter to test the turn signal switch?
twmattox is offline  
post #6 of 8 Old 12-03-2003, 10:08 AM
aviator
 
Join Date: Mar 2003
Posts: 183
Sounds like you may have a problem with the Brake light wiring. Have you inspected the leads coming out of the rear lights?

My guess is that someone has replaced the rear lights at some point and crossed the brake and turn signal wires.

If they were both replaced at the same time, its possible that they are both crossed.

The turn signal swtich harness terminates on the right hand side of the column in a long strip connector.

the turn signal wires are as follows:

Turn signal flasher: Red w/ trace
Hazard Flasher : Pink
Stop switch: pink
LH Tail turn signal: Light Green w/ trace
RH Turn Signal: Light Green
LH Front Turn/marker: Green W/ trace
RH Front turn/marker: Green

If you want to check these, dicsonnect the connector and place your multimeter between the steering column side at the color above, and a good ground. Actuating the switch on the column should provide 12-14 volts to the circuit, therefore you are looking for the same on your meter.

Oh, and all the lights use the chasis as ground, you can also check your grounds on each of the lights. If you have one light not grounded very well, it can throw off the turn signal circuit on that side.

Based on what you're saying, though, I would check for crossed wires first.

I was wrong on one account: It's the round flasher on the right that is the turn signals, not the left.

Last edited by aviator; 12-03-2003 at 10:16 AM.
aviator is offline  
post #7 of 8 Old 12-08-2003, 10:50 PM
smitch
 
Join Date: Dec 2003
Posts: 15
Quote:
Originally Posted by twmattox
I don't have turn signals anymore. My flashers (hazzards) work and all the lights (inside and out) blink, but when I try to use the turnsignals, nothing...all the lights remain dark. I assume it is a problem in the column. Anyone know a way I can test before I take it apart? I was thinking of using my multimeter on the harness, but don't know what to hook up to...


when you figure it out let me know what it was. I just got a 86 cj7 and am having the exact same problem.I have changed fuses and flasher but no help.
smitch is offline  
post #8 of 8 Old 12-09-2003, 07:03 AM Thread Starter
twmattox
Registered User
 
Join Date: Mar 2002
Location: Indianapolis
Posts: 1,333
I think I may have it...
for some reason, when I bought the vehicle, it had only one flasher relay (only for the turn signals). When it went bad, I replaced it, but must have put it into the Hazzard spot. I am going to try to fix it tonight...
twmattox is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
turn signals flashfludjr Jeep CJ Forum 5 03-23-2009 01:01 PM
85 CJ 7 no turn signals ronin2336 Jeep CJ Forum 2 10-29-2008 02:54 PM
'74 CJ5 Turn Signals? Scuter83 Jeep CJ Forum 1 01-18-2007 01:11 PM
Turn signals turn on but dont blink JDGordon Jeep CJ Forum 6 02-27-2006 05:17 PM
turn signals 83 cj-7 258 Jeep CJ Forum 13 07-02-2004 05:00 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome