Need some help on what to do about our Grand Cherokee - JeepForum.com
 
LinkBack Thread Tools
post #1 of 2 Old 09-18-2019, 02:04 PM Thread Starter
cre8nhavoc
Registered User
 
Join Date: Sep 2019
Location: Roseville
Posts: 1
Need some help on what to do about our Grand Cherokee

Hello all,

First time poster and member. This site came highly recommended through a few folks that I know that have said this is one of the better places to get virtually any and/or all information pertaining to Jeep. I sure hope someone here can help to shed some light on our unique situation.

My wife and I purchased a brand new 2017 Jeep Grand Cherokee Overland back in February of 2017. We purchased it through AutoNation Chrysler, Dodge, Jeep, and Ram. Only had a few miles on it and had just about everything we were looking for in our new vehicle. Fast forward to 2019 and our Jeep now has just around 28-29,000 miles. It’s our family car in short.

Beginning of this year, my wife was getting ready to leave work and she was hit with a few error codes on the dash. “Service transmission, service ABS” were the two codes coming up. Being concerned, she contacted the dealership we purchased it from and told them of the issue. Surprisingly, when she turned the car off and then back on, everything was okay. The dealership being just around the corner from my wife’s work (not even a full mile away), they said to drive it in (if it was okay to do so) so they can diagnose the issue. Three days at the dealership and they were unable to locate any issues with ABS and/or the transmission. According to the dealership, they said they saw a bunch of “codes in cache” but couldn’t see anything physically wrong with our brakes or transmission system. We were told to bring it back in if it acts up but they “couldn’t find anything wrong.”

A few weeks later, my wife called me from the parking lot at her work to say that she had the issue come back, but worse. Now she was told that EVERYTING was needing service. “Service ABS, Service transmission, Service 4WD, Service engine, Do not shut engine off (even though the engine was off), do not put in park (even though the car was in park)” and the outside temperature reading kept flickering from 4 to -4 degrees. I told her to take photos and a video of the issue to show the dealership what’s going on this time, to which she did (and we gave them to the service technician too). Ironically, after my wife got out of her car and got back into it later that day, it started up just fine. After that happened, my wife called and notified the dealer that the issue happened again but worse. She drove the Jeep to the dealership with no problems, to which where it’s been ever since. Initial diagnosis found nothing, but they did tell us they were going to replace the entire instrument cluster to our Jeep.

Now with where we are at today, it marks 90 days in the dealership’s possession and we’ve been with a rental ever since. We’ve have got to the point to where we are speaking to a “Specialist” at FCA since the dealership has given us so many different ETA’s on replacement parts and the expectation of when we are to get our vehicle back. Last week (second week of September) the FCA specialist we’ve been working with and keeping us up with the repair ETA said that they no longer have an ETA for when the part should be ready. So as of today, we are still in a rental with no ETA or timeframe with when to expect getting our vehicle back complete with repairs.

So my question to anyone out there who has experience and knowledge in this type of situation is, what do we do now? Given that we are still under factory warranty and that it’s been in the shop’s possession for going on over 90 days now, would this be enough to start looking at requesting a buy-back on our Jeep? Any advice or direction with anyone that’s dealt with this situation (or something similar) would really be appreciated. Thanks.

cre8nhavoc is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old 10-16-2019, 10:48 PM
Steamboatsig
Registered User
 
Steamboatsig's Avatar
2019  
 
Join Date: Sep 2019
Posts: 14
Lemon law?


Sent from my iPhone using Tapatalk

2019 JGC Laredo - 2wd Bone Stock
Steamboatsig is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome