Sliding on mud made all the dash lights come on - JeepForum.com
 
LinkBack Thread Tools
post #1 of 6 Old 08-20-2021, 12:53 PM Thread Starter
Matt2006
Registered User
2006 WK 
 
Join Date: Sep 2017
Posts: 23
Sliding on mud made all the dash lights come on

2006 JGC Limited 4.7 with QD2

I was driving in a muddy construction site going downhill. When I hit the brakes I went into a slide as expected. The anti-lock was working fine and the TC light was coming on. Then as I started hitting some of the bumpier parts all the dash lights came on like it had shut off and restarted. I never felt it shut off but I wasn't watching the tach. Most of the lights went off but several stayed on including TC, abs and seatbelt.

To me it seemed like it lost electrical power for a brief moment. Battery was secure with tight connections. I drive it on forest roads regularly many with holes and rocks that produce more impact than this mud did and It doesn't happen then. However I did slide it around in snow and when it would get traction like mid slide it gave me the lights again.

I have no codes showing. I would prefer it to not cut out on me when I do throw it around some!

Has anyone experienced this before and what is it?

Matt2006 is offline  
Sponsored Links
Advertisement
 
post #2 of 6 Old 08-20-2021, 01:41 PM
GRAND420
Registered User
 
GRAND420's Avatar
 
Join Date: Jun 2018
Posts: 96
You could have gotten mud in your alternator and it almost crapped out on you but it pulled through. When my alternator was dying I was driving down the road and all of my lights started turning on.
GRAND420 is offline  
post #3 of 6 Old 08-20-2021, 02:37 PM
drew54
Registered User
2006 WK 
 
Join Date: Aug 2010
Location: Iowa
Posts: 138
I had something like this happen to me. Your knee probably hit the key and caused a short in the ignition switch.

Has yours been replaced in the prior recall?


Reference: https://www.jeepforum.com/#/topics/4404389
drew54 is offline  
 
post #4 of 6 Old 08-20-2021, 07:27 PM
Vertisce21
Registered User
 
Join Date: Mar 2020
Posts: 256
I've had this happen to me.

You existed in a Grand Cherokee WK that is notorious for having wack *** electrical issues.
Vertisce21 is online now  
post #5 of 6 Old 08-23-2021, 08:01 AM Thread Starter
Matt2006
Registered User
2006 WK 
 
Join Date: Sep 2017
Posts: 23
Thanks for the responses

No it wasn't muddy at all in the engine bay.
It is possible I kneed the ignition. I have not had the recall done because I've read that the new switch is a pain. Also afraid my local dealership will screw it up. They don't have a good reputation.
It is very possible it has wack electrical issues although it has been good despite this particular issue.
Matt2006 is offline  
post #6 of 6 Old 08-24-2021, 12:35 PM
JeepCares
FCA Customer Care
 
JeepCares's Avatar
 
Join Date: Jan 2012
Location: MOPAR World Headquarters
Posts: 5,788
Quote:
Originally Posted by Matt2006 View Post
Thanks for the responses

No it wasn't muddy at all in the engine bay.
It is possible I kneed the ignition. I have not had the recall done because I've read that the new switch is a pain. Also afraid my local dealership will screw it up. They don't have a good reputation.
It is very possible it has wack electrical issues although it has been good despite this particular issue.
Hi Matt2006,
We suggest getting the recall performed for your safety and convenience. If you would like assistance while at the dealer, we are happy to help via private messages.

Rob
Jeep Cares
JeepCares is online now  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome