Rec Radio Sirius - no sound on 184 and can't activate - JeepForum.com
 
LinkBack Thread Tools
post #1 of 1 Old 08-19-2017, 01:39 AM Thread Starter
sgaulin
Registered User
2007 WK 
 
Join Date: Aug 2017
Location: Eugene
Posts: 1
Rec Radio Sirius - no sound on 184 and can't activate

Hi All,

first post here so thanks to all in advance for any info you can share. I have a 2007 WK Overland with REC radio and factory Sirius, but cannot get it to activate and have tried everything short of replacing the REC. The SAT tab displays, but does not respond to volume or channel changes. Disconnected the rear SAT module and the head unit removed the SAT tab, when I plugged it back in SAT tab came back and system showed "channels updating" so I know the REC is seeing and acknowledging the SAT module.

We've tried activating the radio with Sirius Tech support - the door open and closed key in key out thing
I've replaced the Sirius Module in the rear quarter with a known working module
I've replaced the antenna and cable with a known working antenna

Still no sound on 184 and not able to activate. I've even tried to install the PAC aux-in adapter from Crutchfield that emulates the VES system but allows Aux in. The VES tab displays once the PAC is installed but still no sound.

Is this REC system fried or do I need the dealer to update software or enable something for the SAT or VES to fully work?

Thanks to all!

Scott

sgaulin is offline  
Reply

Tags
radio , satellite

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome