Radio Won't Turn On / Fuses Intact - JeepForum.com
 
LinkBack Thread Tools
post #1 of 1 Old 05-30-2019, 10:56 AM Thread Starter
davidh10515
Registered User
 
Join Date: May 2019
Posts: 2
Radio Won't Turn On / Fuses Intact

Hey All,
I just bought a 2005 Jeep Grand Cherokee Limited and it had an aftermarket radio that wouldn't turn on. I checked all the fuses, and they are all intact. I figured the radio was burnt out so I purchased a factory genuine radio online. After plugging it in, still nothing happening. No lights, no sound, nothing.
All the plugs on the current radio and Jeep are factory originals, so wiring shouldn't be a problem. The only clue I can see is a power cord to what must have been an amp that has been removed which leads into the back cargo area, but I can't seem to trace it up into the dash where the radio wiring is.

Any help or suggestions would be greatly appreciated.

davidh10515 is offline  
Reply

Tags
2005 , fuses , not working , radio

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome