P0299 (pending) with P0046 - JeepForum.com
 
LinkBack Thread Tools
post #1 of 4 Old 08-17-2019, 09:18 PM Thread Starter
08WK7180
Registered User
 
08WK7180's Avatar
2008 WK 
 
Join Date: Dec 2018
Location: Spokane
Posts: 74
Garage
P0299 (pending) with P0046

So I was out and around this morning towing a light trailer. Stopped in at home for a little bit and left again. Pretty quickly realized acceleration was lacking pushing the pedal past halfway. Everything seemed fine up until pushing the pedal, including acceleration from a stop as long as pedal is kept under halfway. Knowing something wasn't right I tested it by holding the pedal down further for longer duration and sure enough the lightning bolt started flashing. Scan for codes and got P0299 and P0046. I did some underhood troubleshooting and found that the turbo actuator linkage was not moving at all from key off to key on, startup, acceleration while holding the brake, and key off. Looked to me like a dead actuator.

About that time a friend showed up inviting me to dinner and beer. Partially in frustration I left with her. We had a good time for a couple hours. Now that I'm back I decided to unplug the trailer connector and try starting it up again. I set the camera in place to watch the linkage. Lo and behold the actuator seems to be working fine now. I'm pretty sure the trailer connector had nothing to do with it... or did it? Or was it the two hours of cooling off?


All stock 08 GC Laredo CRD except for swirl motor resistor mod
08WK7180 is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 08-17-2019, 09:47 PM Thread Starter
08WK7180
Registered User
 
08WK7180's Avatar
2008 WK 
 
Join Date: Dec 2018
Location: Spokane
Posts: 74
Garage
Update* I am out test driving it now after finding the actuator appearing to work properly. Runs fine, showing boost and it's back to its normal peppy self. That said I am sure something is failing and I believe it is the actuator intermittently dying. Anyone else have input on this and if I should be looking at other items? Thanks in advance guys.

All stock 08 GC Laredo CRD except for swirl motor resistor mod
08WK7180 is offline  
post #3 of 4 Old 08-20-2019, 12:32 AM
rokrau
Registered User
2008 WK 
 
Join Date: Aug 2016
Location: San Jose
Posts: 105
Turbo Actuators can fail intermittently, at least mine did. It’ll fail again and then a little quicker and then at some point it’ll stay failed.
When it comes back it’ll be time to arrange for a replacement.

—Roland

--Roland, 2008 Grand Cherokee Overland, 3.0 CRD, EHM and TRD
rokrau is offline  
 
post #4 of 4 Old 08-23-2019, 10:59 PM Thread Starter
08WK7180
Registered User
 
08WK7180's Avatar
2008 WK 
 
Join Date: Dec 2018
Location: Spokane
Posts: 74
Garage
So an update: I went ahead and bought an aftermarket turbo actuator. Appears to be built very well and so far works perfectly. Before complete reassembly I plugged it in and turned the key to the on position to verify the actuator cycled correctly and it did. Well I failed to remember the unplugged PCV heater. That caused another code to set, P053A (pcv heater circuit open).

So only issue now is the original P0046 code and the accidental P053A code will not clear. I'm using Torque pro but I don't think it will clear these even though it appears to do so. Does anyone know if it's a situation where I'll have to make several fault-free drive cycles then the PCM will clear them? It hasn't yet thrown the P0299 again. That's good because it means boost is sufficient.

All stock 08 GC Laredo CRD except for swirl motor resistor mod
08WK7180 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome