Odd AC + Power Steering Issues - JeepForum.com
 
LinkBack Thread Tools
post #1 of 3 Old 08-03-2020, 06:31 PM Thread Starter
Jeepwk999
Registered User
2005 WK 
 
Join Date: Sep 2018
Posts: 154
Garage
Odd AC + Power Steering Issues

Hey all,
Currently experiencing a couple odd issues on my 2005 4.7 WK.

One of the most important, because of the season is the AC. It has gradually started blowing warmer and warmer and i thought it just needed a recharge, so today i went and got a can of A/C PRO
to try and recharge it, but it was already filled. I topped it up, and after the AC completely stopped blowing cold air. I noticed the AC compressor engages and disengages every 4-5 seconds.
I also noticed that this causes the idle to drop and fluctuate. The AC compressor is original so maybe it crapped out after 15 yrs?

Second issue is i had a whining sound when driving at lower speeds and rpms. Figured it was power steering, so i checked the fluid and it was almost empty. Topped that up and the sound is still there.
Assuming there is possibly a leak in the power steering hose or pump. Has anyone experienced any of these issues before? Thanks!

Jeepwk999 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 08-04-2020, 06:45 AM
99sajeep
Registered User
 
99sajeep's Avatar
2005 WK 
 
Join Date: Jan 2009
Location: San Antonio
Posts: 763
Quote:
Originally Posted by Jeepwk999 View Post
I noticed the AC compressor engages and disengages every 4-5 seconds.
This is a sure sign that your system is over-filled. Either buy a set of gauges or find someone with a set, and get them connected to the system and see where your pressures are at. Pretty sure they are going to be way high. When slightly over-filled, the AC system on my 5.7 will do the exact same thing.
I would bet that your system is due for a refresh and cleaning.

Quote:
Second issue is i had a whining sound when driving at lower speeds... Topped that up and the sound is still there.
First question: Did you get the Mopar-only recommended hydraulic fluid for the power steering? Or did you just buy regular power steering fluid?

You might be looking at a replacement pump now depending on how long you drove it low on fluid. These pumps don't like running without fluid and it wears the bearings quickly.

I'd first jack the front wheels off the ground (please use jack stands under the frame). With the engine running, turn your front wheels from left to right - full lock to full lock - a bunch of times and see if that will help bleed out some of the air.

If that doesn't help, then you're probably looking at some shop time to get the system replaced and bled.

And keep this in mind...your engine cooling fan is run off the power steering pump. If your pump is bad (or not working at all) you could over heat your engine.

'05 WK 4x4 Ltd 5.7L (mine) 200k+ club
'01 WJ 4x4 Laredo 4.7L (daughter)
99sajeep is offline  
post #3 of 3 Old 08-05-2020, 10:07 AM
Mtndewdude88
Registered User
 
Mtndewdude88's Avatar
2010 WK 
 
Join Date: Mar 2017
Location: Wausau
Posts: 86
Garage
I am replacing a bunch of stuff up front, 2010 5.7L at 92k and figured time for belts, hoses, coolant flush etc. while planing this I noticed the water pump pulley had a little play so figured I would change that out, of course doing the tensioner and idler pulley too as well as thermostat and ETC sensor since I figured the plastic one woulld be unlikely to survive being removed from original pump. The NTK are all brass. anyway this turned into a project cursedby some sort of witchcraft I swear, been fought on every step, while putting the bolts in the water pump and torque to spec, I hit the back of the power steering pump pulley, a little piece chipped off and its seems I also likely broke it. The pulley and shaft can be pulled outwards a bit, few mm maybe. I am nearly positive it was solid as a rock before. My question here is, if it is broke, do i need a new pump, or just the pully? I would assume a whole new pump since the shaft moves with it, and honestly somwhat confused, the service manual for mine talks about the pulley being pressed on in the description, but then under operation talks about the pully being removable. the internet websites have options to buy either the pump or pulley as well? so which is it? visually it looks to be pressed on to me, and again I would assume since the shaft moves with it, even if the pulley was removable the pump is now on its death bed?

Mike
Mtndewdude88 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome