My JEEP's 65th anniversary - JeepForum.com
 1Likes
  • 1 Post By bumzo1
 
LinkBack Thread Tools
post #1 of 6 Old 07-13-2020, 07:25 PM Thread Starter
b18roman
Registered User
 
Join Date: Jul 2020
Posts: 3
My JEEP's 65th anniversary

I'm a newbie in the forum but not of owning Jeeps. This is however my first Grand Cherokee and it happens to be a 65th anniversary edition (2006). I'm having issues with the a/c only blowing cold air on the driver side and hot air on the passenger side. Also, last week it was blowing white smoke. The jeep did not give indication of any problems, no lights, and it was not overheated. My mechanic said it was the blend doors but what about the white smoke? He couldn't say.

Now, it only smoked for a few minutes, I turned a/c off, turned it back on an hour or so later and it stopped smoking. It only happen once.

I like to fix it myself, if someone could send me links on how to take out the dash correctly, I would be most grateful.

Engine v6
automatic
4x4
no aftermarket installed

Bonnie
U.S. Navy Veteran.

b18roman is offline  
Sponsored Links
Advertisement
 
post #2 of 6 Old 07-13-2020, 10:31 PM
bumzo1
Registered User
 
bumzo1's Avatar
2005 WK 
 
Join Date: May 2010
Location: Texas
Posts: 1,188
Does your Jeep have the dual zone automatic climate control? If it doesn't, cooling on the drivers side and hot on the passenger is an indication that you are low on refrigerant and most likely have a leak somewhere. I would recommend taking it to a shop and having them do a pressure/leak test. I had trouble with the schrader valves leaking on my 2005 but it could really be anywhere.
b18roman likes this.

'05 WK 3.7L QT1 OME MD lift
'09 WK 5.7L QDII Stock for Now
Khaki WK Club Member #1
bumzo1 is online now  
post #3 of 6 Old 07-14-2020, 01:41 PM Thread Starter
b18roman
Registered User
 
Join Date: Jul 2020
Posts: 3
I took it to Firestone today, describe the symptoms. They are "confident" its not a leak otherwise I would get no cold air at all. I don't know how much I can trust them. And it's not a dual systems. The only videos and information I find is for WJ, prior 2005. The 2006 grand cherokee I do find is on the actuator replacement and no blend doors.

Your help is much appreciated.
Thank you.
b18roman is offline  
 
post #4 of 6 Old 07-14-2020, 07:08 PM
bumzo1
Registered User
 
bumzo1's Avatar
2005 WK 
 
Join Date: May 2010
Location: Texas
Posts: 1,188
Did they actually hook it up to a set of gauges to check the pressures? How long has this behavior been going on for? Try turning the hot/cold knob and see if the temp changes. If it does I think the blend doors are working properly. Do the same for the other knob and see if it directs air to the appropriate vents. When the A/C went out on my '05 there was a temperature gradient between driver and passenger, and then a few days later it didn't cool at all. In my case it was a leaky schrader valve.

Looks like this other forum member is having the same issue https://www.jeepforum.com/forum/f67/...oblem-4400159/

'05 WK 3.7L QT1 OME MD lift
'09 WK 5.7L QDII Stock for Now
Khaki WK Club Member #1
bumzo1 is online now  
post #5 of 6 Old 07-15-2020, 07:36 AM
nvrdone1
Registered User
2007 WK 
 
Join Date: Sep 2014
Location: duvall
Posts: 645
if you have a leak, generally its a small one and as the freon leaks out the cooling ability declines. Id run fast away from that Firestone shop and find one that does a/c work.
nvrdone1 is offline  
post #6 of 6 Old 07-15-2020, 09:29 AM
Grinmaul
Registered User
2008 WK 
 
Join Date: Nov 2018
Location: scarborough
Posts: 144
Quote:
Originally Posted by b18roman View Post
I took it to Firestone today, describe the symptoms. They are "confident" its not a leak otherwise I would get no cold air at all. I don't know how much I can trust them. And it's not a dual systems. The only videos and information I find is for WJ, prior 2005. The 2006 grand cherokee I do find is on the actuator replacement and no blend doors.

Your help is much appreciated.
Thank you.

They my be confident, but they are probably still wrong. just went through this myself. turns out it was a leak.


take it somewhere else.

2 2008.5 WK CRD's, 2005 WK Limited 5.7
Grinmaul is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome