Interior Electrical Problem - JeepForum.com
 
LinkBack Thread Tools
post #1 of 6 Old 10-16-2015, 07:11 AM Thread Starter
LIONJR242
Registered User
2007 WK 
 
Join Date: Nov 2012
Location: Miami
Posts: 5
Interior Electrical Problem

List of issues that started at the same time in my '07:

1) Driver side door controls do not function including front windows, side mirrors, window and door locks.

2) Interior dome light does not function

3) Stereo must be manually shut off after ignition is turned off and key removed

Any ideas?

LIONJR242 is offline  
Sponsored Links
Advertisement
 
post #2 of 6 Old 10-16-2015, 08:31 AM
sfjacks1
Registered User
2004 WJ 
 
Join Date: Feb 2012
Location: Salem
Posts: 124
Check the wiring going into the drivers door, I bet you will find a broken wire. It was a all to common problem on the WJ, there will be a broken wire (poss ground) in the boot
sfjacks1 is offline  
post #3 of 6 Old 10-16-2015, 02:55 PM
tom19511
Registered User
2014 WK 
 
Join Date: Mar 2009
Location: Sheffield Lake
Posts: 1,102
Check the fuses and relays...
http://www.wkjeeps.com/wk_fuses.htm

Tom

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
tom19511 is offline  
 
post #4 of 6 Old 10-19-2015, 09:53 AM
JeepCares
FCA Customer Care
 
JeepCares's Avatar
 
Join Date: Jan 2012
Location: MOPAR World Headquarters
Posts: 5,261
Quote:
Originally Posted by LIONJR242 View Post
List of issues that started at the same time in my '07:

1) Driver side door controls do not function including front windows, side mirrors, window and door locks.

2) Interior dome light does not function

3) Stereo must be manually shut off after ignition is turned off and key removed

Any ideas?
Hey LIONJR242,

TSB 08-015-07 may relate to your vehicle:

SUBJECT:
Flash:Sunroof Module, Excessive Ignition Off Draw, Pop In Radio with Ignition Off, Dome
Lamp Flickers And May Not Go Off
OVERVIEW:
This bulletin involves selectively erasing and reprogramming the Sunroof Motor Module
with new software.
MODELS:
2006 - 2007 (LE) 300, Touring (International Markets)
2006 - 2007 (LX) 300, Charger, Magnum
2007 (L2) 300 (China)
2006 - 2007 (WK) Grand Cherokee
2006 - 2007 (WH) Grand Cherokee (International Markets)
2006 - 2007 (XK) Commander
2006 - 2007 (XH) Commander (International markets)
2006 - 2007 (DR) Ram truck
SYMPTOM/CONDITION:
Some customers may experience a software issue in the Sunroof Motor Module causing
the Vehicle Communication System (BUS) to stay active after the vehicle is shut down.
This condition can cause any of the following symptoms:
Dead battery after vehicle has not been used for 2 or more days due to excessive
ignition off draw
Popping sound in radio or thumping sound from speaker/subwoofer when operated
with the ignition off. This can occur with the radio off.
Interior lighting flickering or not turning off after the vehicle is shut down.

Please let me know if you have any further questions.
JeepCares is online now  
post #5 of 6 Old 12-13-2015, 09:43 AM
BlackRat
Registered User
2010 WK 
 
Join Date: Dec 2014
Location: Texarkana
Posts: 5
did you ever figure out what was causing this problem

my 2010 wk just started having the same problem but i have a few more things not working.

My airbag light is on, my door sensor does not know the door is open or closed. front windows dont work, door locks only work from key fob, i have no heat or air, rear heated seats dont work, and park assist doesnt work but the back up camera does, none of the interior, courtsey, glove box lights work and thats all i have found so far
BlackRat is offline  
post #6 of 6 Old 12-15-2015, 08:20 AM
JeepCares
FCA Customer Care
 
JeepCares's Avatar
 
Join Date: Jan 2012
Location: MOPAR World Headquarters
Posts: 5,261
Quote:
Originally Posted by BlackRat View Post
my 2010 wk just started having the same problem but i have a few more things not working.

My airbag light is on, my door sensor does not know the door is open or closed. front windows dont work, door locks only work from key fob, i have no heat or air, rear heated seats dont work, and park assist doesnt work but the back up camera does, none of the interior, courtsey, glove box lights work and thats all i have found so far
Hey BlackRat,

If these conditions are all constant, I would advise you to have the vehicle formally diagnosed at a certified FCA dealership.
JeepCares is online now  
Reply

Tags
electrical issue , ignition , radio

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome