HELP! Front windows and door mirrors not working - JeepForum.com
 1Likes
  • 1 Post By nwoods
 
LinkBack Thread Tools
post #1 of 5 Old 09-14-2021, 11:14 AM Thread Starter
Rabz101
Registered User
 
Join Date: Jun 2021
Posts: 9
HELP! Front windows and door mirrors not working

Hey guys, boring one but I need this sorted ASAP.

I started my jeep and put the windows down no problems. Then I noticed the left wing mirror was fully down (looking at the road) so tried to put it back up and there was no power going to it. Then I realised I couldn't put my windows back up either.

There rear windows are still working on the drivers door controls but not the front windows or wing mirror controls. The passenger side front door control doesn't work either. So I currently have the front windows stuck down.

I've checked the wires on the drivers door and they seem fine from what I can tell. Can anyone help please?

Rabz101 is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old 09-14-2021, 11:22 AM Thread Starter
Rabz101
Registered User
 
Join Date: Jun 2021
Posts: 9
The only buttons that work on the drivers door controls are the rear windows and the window lock button. Not sure if that helps at all.....
Rabz101 is offline  
post #3 of 5 Old 09-14-2021, 12:21 PM Thread Starter
Rabz101
Registered User
 
Join Date: Jun 2021
Posts: 9
So it was just a switch fuse which is sorted. Can't seem to delete the thread though
Rabz101 is offline  
 
post #4 of 5 Old 09-15-2021, 12:28 PM
nwoods
Registered User
2006 WK 
 
Join Date: Jul 2008
Location: SoCal
Posts: 179
Garage
Rather than delete the thread, it would be great if you could finish it by posting what fuse it was that fixed your issue, and maybe a picture of where it is located.
Videojam likes this.

2006 Jeep WK on 33ís
HAM: KI6FPO
Offroad Photography:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
nwoods is offline  
post #5 of 5 Old 09-15-2021, 12:44 PM
Videojam
Registered User
 
Videojam's Avatar
 
Join Date: Aug 2017
Location: Chicago
Posts: 10
Quote:
Originally Posted by nwoods View Post
Rather than delete the thread, it would be great if you could finish it by posting what fuse it was that fixed your issue, and maybe a picture of where it is located.

Yes, please do this!
Videojam is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome