CRD fuel return test - Page 2 - JeepForum.com
 4Likes
Reply
 
LinkBack Thread Tools
post #16 of 17 Old 11-03-2019, 11:48 AM
Tetto
Registered User
 
Join Date: Oct 2015
Location: Fort Collins
Posts: 38
Garage
Thanks for posting an update! I had given up on mine but in rereading this thread, I got inspired again as we're experiencing the exact same thing. I feel like when one of us figures it out, it'll fix both of our Jeeps

I grabbed a fresh set of data during today's hard start. I wanted to get a good capture of engine RPM vs fuel rail pressure, but I forgot to enable actual data logging, leaving me with just graphs. Since I've got to wait a few hours for the engine to return to cold again, I'll post what I've got. It's probably not too helpful, but I figure if we'll get something useful between our sets of data.

I hadn't noticed until now, but the rail pressure was steady at ~6K PSI on the first start attempt, then ~4K PSI on subsequent starting attempts and when idling. It seems that 4K PSI is normal - I wonder if 6K PSI is over-pressured...

Attached Thumbnails
PSI_comments.jpg  
Tetto is offline  
Sponsored Links
Advertisement
 
post #17 of 17 Old 11-04-2019, 02:02 PM Thread Starter
08WK7180
Registered User
 
08WK7180's Avatar
2008 WK 
 
Join Date: Dec 2018
Location: Spokane
Posts: 90
Garage
If I recall correctly my key on engine off rail pressure hovers around 60psi. Engine cranking rail pressure around 300psi, and idling rail pressure just above 4000psi. I don't recall where I read it, but these pressures are about normal. Not sure if 6000 idling is too high but something to consider.

Mine hasn't yet timed out due to excessive cranking. It sometimes cranks for uncomfortably long though. There is a definite correlation to plugging in the block heater with almost perfect starts. That's what got me thinking about the glow plug system.

At the same time I feel like I also have an intermittent fuel pressure issue. After noticing the slight momentary drop in rail pressure just as the engine revs past 1100rpm I poked around some more. The momentary drop exactly coincides with an light squeak/rattle from somewhere in the rotating assembly at the front of the motor. The sound is like a dry shaft/bushing quiet until hitting 1100rpm. Makes me wonder if the gerotor in the high pressure fuel pump is worn. If I graph the rail pressure right after a cold start it drops about 300 to 400 psi for a split second as it revs up past 1100rpm with the corresponding noise up front and the slight engine stumble. Almost seems like I'm answering my own questions as I analyze my findings. However, I still want to hear from others who may be familiar.

All stock 08 GC Laredo CRD except for swirl motor resistor mod
08WK7180 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome