2006 WK Hemi Running Slightly Hot on Highway - JeepForum.com
 2Likes
  • 1 Post By nvrdone1
  • 1 Post By GRAND420
 
LinkBack Thread Tools
post #1 of 8 Old 08-04-2020, 05:46 PM Thread Starter
GRAND420
Registered User
 
Join Date: Jun 2018
Posts: 11
2006 WK Hemi Running Slightly Hot on Highway

Hello everyone, lately I've noticed that my temperature gauge goes a little bit past center on the highway. Once I'm in the city or even at idle it's slightly below dead center. Has anyone here experience something like that or have any idea of what would cause it? Or if it's even something I should worry about?

GRAND420 is online now  
Sponsored Links
Advertisement
 
post #2 of 8 Old 08-05-2020, 12:57 AM
powerstroke01
Registered User
 
powerstroke01's Avatar
2005 WK 
 
Join Date: Jan 2004
Location: Ahwahnee
Posts: 613
Dont worry about it. Middle of the guage is maybe 219. Hemi likes it hot. THe motor is programmed to try to stay at 217//

Jeepers do it in the mud. ;)
powerstroke01 is offline  
post #3 of 8 Old 08-05-2020, 10:02 AM
nvrdone1
Registered User
2007 WK 
 
Join Date: Sep 2014
Location: duvall
Posts: 655
my 07 hemi temp varies depending on the outside temp. if its mid 70's the gauge stays right below the 1/2 mark. if its mid 80's or above its just above 1/2. doesnt change at freeway or city speeds. i did find when i had my 7" hellas mounted on top of the bumper, she did tend to run a bit hotter. hemis really like good air flow.
nvrdone1 is offline  
 
post #4 of 8 Old 08-05-2020, 01:41 PM Thread Starter
GRAND420
Registered User
 
Join Date: Jun 2018
Posts: 11
Okay that makes me feel a little better. It's just odd to me that it just started doing it. It's also strange that it only past center on the highway and it goes down to slightly left of center in town and idling. I would think it would be opposite. Also being a 2006, I want to baby it temp wise do to the possible valve seat issue.
GRAND420 is online now  
post #5 of 8 Old 08-05-2020, 02:11 PM
nvrdone1
Registered User
2007 WK 
 
Join Date: Sep 2014
Location: duvall
Posts: 655
i would get an infared temp gun and measure the temp at the thermostat cover. could be that your sending unit is giving you a false reading. the temp should remain constant except when caught in stop & go traffic. good luck.
powerstroke01 likes this.
nvrdone1 is offline  
post #6 of 8 Old 08-05-2020, 07:42 PM Thread Starter
GRAND420
Registered User
 
Join Date: Jun 2018
Posts: 11
I might just do that. Seems like a justifiable reason to buy a IR gun lmao
powerstroke01 likes this.
GRAND420 is online now  
post #7 of 8 Old 08-06-2020, 09:26 AM
99sajeep
Registered User
 
99sajeep's Avatar
2005 WK 
 
Join Date: Jan 2009
Location: San Antonio
Posts: 764
Or get a scanner that is capable of reading Live Data ($25-$50) and check your temps while running. That's the most accurate way.
My 05 Hemi will run 210-212 while sitting at a light here in a nice "warm" Texas summer. Highway temps get up to about 215-217 if sitting in slow-moving traffic. While running highway speeds, it drops down to about 212.

'05 WK 4x4 Ltd 5.7L (mine) 200k+ club
'01 WJ 4x4 Laredo 4.7L (daughter)
99sajeep is offline  
post #8 of 8 Old 08-07-2020, 12:21 PM Thread Starter
GRAND420
Registered User
 
Join Date: Jun 2018
Posts: 11
I ordered vgate so I can use jscan. Hopefully that will give me a better idea of what's going on.
GRAND420 is online now  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome