2006 Grand Cherokee 4.7 P0339 & P0300 core - JeepForum.com
 
LinkBack Thread Tools
post #1 of 8 Old 05-24-2019, 10:41 PM Thread Starter
904block
Registered User
 
Join Date: May 2017
Posts: 32
2006 Grand Cherokee 4.7 P0339 & P0300 core

So the other day I was home . And out of no where my check engine came on when I was at the red light so I didn't think was urgent so I had planned to wait when I got home . So when I started to accelerate my Jeep started buckling or Stumbling hard so I pulled into a gas station Read the code P0339 so I disconnected the battery for 10 seconds and the check engine light didn't come back on, but since the Crank sensor was from Autozone I decided to replace it. So when I installed the new sensor and started my Jeep the RPM's started jumping and it seemed like the Jeep wanted to stall out. So I shut the Jeep off disconnected the battery installed the warranty sensor for another new one and same results . But now with the P0300 code

So this is what I Ruled out

(1)The battery and Starter the Jeep turns over no problem

(2) The Cam Position Sensor I replaced it last summer

(3) Throttle Position Sensor recently replace

(4) Ignition Coils less than a month old

(5) Crank Sensor I replaced it with three new sensor at AutoZone

Sorry I'm making this longer than it should be I'm trying to gave more details . But iam going to the junkyard tomorrow to remove a Crank sensor and wire Harness from another Jeep just in case the wire is burnt since there on back order at the dealership

904block is offline  
Sponsored Links
Advertisement
 
post #2 of 8 Old 05-24-2019, 10:49 PM Thread Starter
904block
Registered User
 
Join Date: May 2017
Posts: 32
And by the way I do my oil changes every 5k and spark plugs , Air filter , every 10-15k
904block is offline  
post #3 of 8 Old 05-25-2019, 11:28 AM Thread Starter
904block
Registered User
 
Join Date: May 2017
Posts: 32
Update so I went to the Junkyard and pull a Crank sensor out a different Jeep and guess what? All my problems went away stay away from Autozone for some parts
904block is offline  
 
post #4 of 8 Old 05-25-2019, 01:53 PM
RCS1300
Registered User
2005 WK 
 
Join Date: May 2014
Location: Stamford
Posts: 1,312
Autozone is not the problem. Jeeps like only OEM sensors.
RCS1300 is offline  
post #5 of 8 Old 05-27-2019, 09:33 AM
YJ325i
Registered User
2007 XK Commander 
 
Join Date: Apr 2015
Location: Denver
Posts: 16
In AZ defense, I had a WK 4.7L once that has sync codes. Got a crk/cam set from dealer. Same codes, almost started checking the chain, on a whim got a set from AZ. Fixed. Sometimes itís just the luck of the batch. Also, maybe the connector was the real fix🤔

95 YJ 2.5L 33" BFG mt's 8.8 sye 4Ē lift
94 ZJ 4.0L 97 TJ Sahara
Past: 95 & 96 XJís 04 Liberty
YJ325i is offline  
post #6 of 8 Old 05-28-2019, 10:21 AM Thread Starter
904block
Registered User
 
Join Date: May 2017
Posts: 32
Maybe it was that particular Sensor from AZ didn't work because I tried three different sensors from AZ of the same Part number and it wasn't working but I believe the AZ sensor had a different Ohm than the dealership sensor
904block is offline  
post #7 of 8 Old 05-28-2019, 10:22 AM Thread Starter
904block
Registered User
 
Join Date: May 2017
Posts: 32
But I never changed the connector I just put in a sensor from the dealer and the problems went away
904block is offline  
post #8 of 8 Old 05-28-2019, 02:46 PM
2005JGC
Registered User
 
2005JGC's Avatar
2005 WK 
 
Join Date: Dec 2017
Location: Portland
Posts: 386
Garage
I stay away from aftermarket sensors for Chrysler as much as possible! Even if it works out the gate, they never last as long in my experience. Dealt with 1 too many customers pissed off that their PT Cruiser was just towed in because it needs a new camshaft position sensor when they just paid a shop 6 months ago to replace it. There is not really any aftermarket brand that I would stand behind on a Chrysler product, every. single. one. would be sold with the "this may not last very long" caveat.

2005 Jeep Grand Cherokee - Work in progress...
2005JGC is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
WJ 4.7 Alternator replacement & upgrade write-up Uniblurb WJ Grand Cherokee Forum 27 05-20-2019 01:23 PM
08 4.7 Gr Cherokee P0300 Megalodon47 Engines & Drivetrain 5 03-22-2019 10:08 PM
2006 Commander 4.7 CommanderBebop Commander 0 12-23-2018 09:56 AM
Overheated 4.7 2006 XK - Blown head gasket? caveman69 WK Grand Cherokee & XK Commander Forum 2 12-08-2018 04:48 AM
2006 4.7 Misfire wesilva WK Grand Cherokee & XK Commander Forum 2 09-12-2018 08:28 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome