2005 Grand Cherokee not cranking after repair - JeepForum.com
 
LinkBack Thread Tools
post #1 of 3 Old 06-15-2021, 01:51 PM Thread Starter
FrankyT66
Registered User
 
Join Date: Jun 2021
Posts: 2
2005 Grand Cherokee not cranking after repair

Gents I‘m desperately looking for help. I had to remove the right valve cover of my 2005 3.7L Laredo to check the lifters. For this I had removed the A/C comp, generator, ign coils, ign valves, intake manifold and much of the related wiring. After putting everything back the engine will not crank. The scanner shows U0100 and P657. Any idea what to check?
I‘m an experienced automotive electronic developer but lacking the Jeep diagnostic tools and wiring schematics. Hope somebody can help.
Greetings from Germany
Frank

FrankyT66 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 06-15-2021, 01:59 PM Thread Starter
FrankyT66
Registered User
 
Join Date: Jun 2021
Posts: 2
One more thing: when trying to crank the instrument cluster shows: „check gauges“
FrankyT66 is offline  
post #3 of 3 Old 06-16-2021, 08:55 AM
Shark_13
Registered User
1998 TJ Wrangler 
 
Join Date: Dec 2012
Location: Post falls
Posts: 2,141
Garage
Is doesn't turn over at all? Any clicking?

I'd remove and clean battery terminals and make sure battery is not dead.

Sent from my SM-G960U using Tapatalk

Get out and explore.
Shark_13 is online now  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome