09 Hemi stalling at low speeds - JeepForum.com
 
LinkBack Thread Tools
post #1 of 3 Old 03-27-2016, 02:11 PM Thread Starter
ryco25
Registered User
2009 WK 
 
Join Date: Apr 2014
Location: St. Louis
Posts: 21
09 Hemi stalling at low speeds

I'm having a strange intermittent issue where my 2009 Grand Cherokee Limited w/ the 5.7 stalls at low speeds. It only happens in very specific situations, and not all the time.

It only stalls on me when I enter a parking garage and go over a speed bump at low speeds. As soon as I crest the bump, it completely dies and I have to shift into neutral or park depending on my speed and start it again. When I start it, it has a really weak start as it sputters back to life.

This happens like once every few weeks..I drive through parking garages with speed bumps multiple times daily, but this only happens every now and then. Thought it originally could be due to my tune I was running, but it is currently detuned and it is still happening.

This could be a multitude of things, but of course the dealer can't find anything during a diagnostic.

Has anyone had this issue?

ryco25 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 03-27-2016, 04:45 PM
Montreal300
Registered User
 
Montreal300's Avatar
1999 WJ 
 
Join Date: Jan 2015
Location: Saint Lazare
Posts: 950
When is the last time you cleaned out the throttle body? I had the same problem that you describe and it went away after a cleaning. Do it right by removing it and cleaning before and after the blade. If you use TB cleaner, hold the TB so the electronics are at the 12:00 position and don't spray the shaft where it exists to TB to the motor The TB electronics do not like cleaner on the board.
Montreal300 is offline  
post #3 of 3 Old 03-27-2016, 05:51 PM
Jeep Brian
Registered User
 
Join Date: Dec 2006
Location: Bergen county
Posts: 436
Garage
Have you done a tune up on it?? Putting the wrong plugs in WILL MAKE it stall.

Mine: 07 GC Limited Hemi stock for now.

Hers: 14 Dodge Durango Citadel Hemi

68 Firebird 350 4 spd #'s matching
Jeep Brian is offline  
Reply

Tags
2009 , grand cherokee , hemi , low speed , stalling

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome