Another new guy - JeepForum.com
 
LinkBack Thread Tools
post #1 of 8 Old 08-11-2020, 11:16 AM Thread Starter
wpod
Registered User
 
Join Date: Aug 2020
Posts: 94
Another new guy

Quite a process I had to go through to get here. Hope it cuts down on bots.
Bought an 04 WJ Larado a few weeks ago. Mostly for son to drive. The vehicle it replaced (05 Dodge Magnum) has a simple issue that I can't figure out.
Anyway, the WJ is seemingly all stock(ish). 125k miles on it, it AZ appears to not have been offroad. There's one tiny parking lot doing. But it is better suited to where we live than the Magnum.
NW corner of AZ, very rural. A few miles of rutted dirt (mud) roads to go anywhere. Lots of 4x4 trails, even the (roads) can present a challenge. All the drive functions work as they are supposed to. No issues with the WJ. It does appear the radio has been changed and there is a camera on the tailgate with the interior end dangling. There is no screen on the radio so it doesn't go there.
Besides the dead Magnum we also have:
Wifes 07 Dodge Ram 2500 quad cab long bed 4x4.
My 17 4runner SR5 (lifted, oversize tires, etc) and my 68 Ford F100 that the 4runner supplements.
Three street bikes and a quad. Need more quads.
So, I've been lurking up until now seeing issues I may encounter with the WJ. I used to be parts manager at a Jeep specialty garage in the early 90's, though until I got the 4runner last November, I've never been offroading.
I'm here to learn. Old dog/new tricks thing (61 years old)

Sent from my SM-G955U using Tapatalk


wpod is offline  
Sponsored Links
Advertisement
 
post #2 of 8 Old 08-13-2020, 01:13 PM Thread Starter
wpod
Registered User
 
Join Date: Aug 2020
Posts: 94
We really like the Jeep

Sent from my SM-G955U using Tapatalk
wpod is offline  
post #3 of 8 Old 08-14-2020, 05:41 AM Thread Starter
wpod
Registered User
 
Join Date: Aug 2020
Posts: 94
Thank you.

Sent from my SM-G955U using Tapatalk
wpod is offline  
 
post #4 of 8 Old 08-20-2020, 05:08 AM Thread Starter
wpod
Registered User
 
Join Date: Aug 2020
Posts: 94
Still running. No issues.

Sent from my SM-G955U using Tapatalk
wpod is offline  
post #5 of 8 Old 08-26-2020, 09:00 AM Thread Starter
wpod
Registered User
 
Join Date: Aug 2020
Posts: 94
200 views. Tough crowd.

Sent from my SM-G955U using Tapatalk
wpod is offline  
post #6 of 8 Old 09-21-2020, 03:30 AM Thread Starter
wpod
Registered User
 
Join Date: Aug 2020
Posts: 94
Son still liking the WJ, no problems yet.
Got a new OEM receiver hitch and bezel. Waiting on the wiring so I remove the bumper once.
Protection for the Pinto fuel tank and a recovery point.

Sent from my SM-G955U using Tapatalk
wpod is offline  
post #7 of 8 Old 09-22-2020, 05:06 PM Thread Starter
wpod
Registered User
 
Join Date: Aug 2020
Posts: 94
Installed the OEM receiver and bezel. Managed to not have to remove the bumper fascia.

Went on without a hitch.

I do see a minor benefit to to two braces. There was one brace, left side, from "frame" to skid that had to be removed.

Just need wiring now.

Screws will be replaced on the bezel with the correct plastic rivets this evening when it cools down, though it's only 95 today.

This receiver sits higher than the aftermarket receivers. Pulling load is more inline with the "frame".

Happy to have better protection for the fuel tank.

Sent from my SM-G955U using Tapatalk
wpod is offline  
post #8 of 8 Old 09-30-2020, 07:15 AM
JohnWPB
Junior Member
 
JohnWPB's Avatar
1995 YJ Wrangler 
 
Join Date: Sep 2020
Location: West Palm Beach
Posts: 21
Tell me about it! I've posted a couple of topics and they're still not showing up. I guess I have another 15 or so posts to make. The 25 post requirement seems a little stupid if I must be honest. It just clutters up the forearm with a bunch of useless posts, just to get a post to count high enough to be able to use the form properly.

I paid for a subscription to The Forum, and supposedly with a paid subscription you don't have these restrictions, this doesn't seem to be the case 😞

1995 Jeep YJ 2.5l 5 speed manual. Otherwise known as "Mariah"
JohnWPB is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome