New to Wagoneer's, advice needed - JeepForum.com
 
LinkBack Thread Tools
post #1 of 4 Old 10-04-2018, 06:46 AM Thread Starter
WeBeCinYa
Registered User
 
Join Date: Jan 2012
Location: Denver
Posts: 73
New to Wagoneer's, advice needed

Hello-

I have always wanted a Wagoneer and have an opportunity at one but wanted some advice. My background is Land Rovers, I have had 10 or so various Range Rover Classics, Defender and Series trucks. I know from experience that rust and rot are #1 concern in that arena, that should be concern on any vehicle imo. What I am looking for here is advice on what to look for on Wagoneers when purchasing one.

I have looked over this potential buy briefly, and it is at a mechanic's shop now so they have had eye on it too.

100k miles, all original, no rust noted in any wheel well or frame, some surface rust (more like paint flake) on some under carriage components, no evidence of body work or bondo, pretty complete inside just dirty. Was in to the mechanic for exhaust leak, repair AC, tune up/fluids, and power window regulator. Mechanic said it runs strong, no leaks.

Where should I look for issues? When I drive it what should I look for?

All help appreciated! Thanks in advance...


2012 WK2 Laredo Stone White, QTII, Leather, 20" Overland wheels, 275/55/20, All weather pkg, towing pkg
1942 Ford GPW Military Jeep
WeBeCinYa is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 10-04-2018, 07:02 AM
SemperFiGuy
Registered User
1980 CJ5 
 
Join Date: Mar 2014
Posts: 731
What year are we talking here?



Sent from my iPhone using Tapatalk
SemperFiGuy is offline  
post #3 of 4 Old 10-04-2018, 07:41 AM Thread Starter
WeBeCinYa
Registered User
 
Join Date: Jan 2012
Location: Denver
Posts: 73
Quote:
Originally Posted by SemperFiGuy View Post
What year are we talking here?



Sent from my iPhone using Tapatalk
1991

2012 WK2 Laredo Stone White, QTII, Leather, 20" Overland wheels, 275/55/20, All weather pkg, towing pkg
1942 Ford GPW Military Jeep
WeBeCinYa is offline  
 
post #4 of 4 Old 10-05-2018, 06:36 AM
SemperFiGuy
Registered User
1980 CJ5 
 
Join Date: Mar 2014
Posts: 731
Nice, last year. Check really well where the fuel tank mounts on the frame. Also check the front floor boards thoroughly, especially up near the front. Oil pressure at cold and warm. 4wd. Any sort of lift, make sure itís not rag tag, lifted properly. Rear window up and down. Lock knobs stay up, lock, unlock. New distributor perhaps, ask about the cam gear. Should have kept the old distributor gear on. Lights, especially in front. Fog, hi/low beam. Thatís all problems I had with mine. Wait one more, rag joint from the shaft to the gear.


Sent from my iPhone using Tapatalk
SemperFiGuy is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome