Rough Idle - JeepForum.com
 
LinkBack Thread Tools
post #1 of 13 Old 06-20-2016, 10:18 PM Thread Starter
Wheels447
Registered User
1988 MJ Comanche 
 
Join Date: Jun 2016
Posts: 7
Rough Idle

hi my 1988 jeep comanche has a rough idle from lets say 900 normal then drops to 150 or so relay bad then it go's back to normal but some times it dose do it then others its normal


i have replaced the IAC valve and TPS i dont know what else it could be

Wheels447 is offline  
Sponsored Links
Advertisement
 
post #2 of 13 Old 06-21-2016, 07:37 AM
cruiser54
Web Wheeler
 
cruiser54's Avatar
1990 MJ Comanche 
 
Join Date: Oct 2009
Location: Prescott
Posts: 12,025
Before wasting any more time or spending any money, make sure your intake manifold bolts haven't loosened up and then go to www.cruiser54.com and do Tips 1 through 5 thoroughly.

If you own a Renix Jeep, you must check this out:


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


My Jeep technical photos:


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
cruiser54 is offline  
post #3 of 13 Old 06-21-2016, 05:32 PM Thread Starter
Wheels447
Registered User
1988 MJ Comanche 
 
Join Date: Jun 2016
Posts: 7
Ok will do think you
Wheels447 is offline  
 
post #4 of 13 Old 06-23-2016, 07:50 AM
cruiser54
Web Wheeler
 
cruiser54's Avatar
1990 MJ Comanche 
 
Join Date: Oct 2009
Location: Prescott
Posts: 12,025
Quote:
Originally Posted by Wheels447 View Post
Ok will do think you
Tip 8 shows you how to adjust the tPS properly.

If you own a Renix Jeep, you must check this out:


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


My Jeep technical photos:


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
cruiser54 is offline  
post #5 of 13 Old 08-09-2016, 12:17 PM Thread Starter
Wheels447
Registered User
1988 MJ Comanche 
 
Join Date: Jun 2016
Posts: 7
Ok so it has not gotten any better someone told me that it could be a compression problem
Wheels447 is offline  
post #6 of 13 Old 08-10-2016, 03:43 PM
cruiser54
Web Wheeler
 
cruiser54's Avatar
1990 MJ Comanche 
 
Join Date: Oct 2009
Location: Prescott
Posts: 12,025
Quote:
Originally Posted by Wheels447 View Post
Ok so it has not gotten any better someone told me that it could be a compression problem
Could be many things.

Do a compression test and post up the results.

Could be worn out tune up parts, bad oxygen sensor etc etc.

If you own a Renix Jeep, you must check this out:


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


My Jeep technical photos:


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
cruiser54 is offline  
post #7 of 13 Old 03-29-2017, 12:34 PM Thread Starter
Wheels447
Registered User
1988 MJ Comanche 
 
Join Date: Jun 2016
Posts: 7
Compression is good but now I have a new problem sometimes when I drive in second gear and up when I get to in between 2100rpm and 2600rpm it back fires a lot but once it gets out of that it drives fine and it really random when it dose it I replaced every thing electrical except the computer and it still dose it
Wheels447 is offline  
post #8 of 13 Old 03-29-2017, 04:06 PM
cruiser54
Web Wheeler
 
cruiser54's Avatar
1990 MJ Comanche 
 
Join Date: Oct 2009
Location: Prescott
Posts: 12,025
Quote:
Originally Posted by Wheels447 View Post
Compression is good but now I have a new problem sometimes when I drive in second gear and up when I get to in between 2100rpm and 2600rpm it back fires a lot but once it gets out of that it drives fine and it really random when it dose it I replaced every thing electrical except the computer and it still dose it
Ever been here..www.cruiser54.com... and done tips 1 through 5?

If you own a Renix Jeep, you must check this out:


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


My Jeep technical photos:


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
cruiser54 is offline  
post #9 of 13 Old 03-29-2017, 11:00 PM
Nick05
Registered User
1994 XJ Cherokee 
 
Join Date: Jan 2013
Posts: 708
Quote:
Originally Posted by Wheels447 View Post
Compression is good but now I have a new problem sometimes when I drive in second gear and up when I get to in between 2100rpm and 2600rpm it back fires a lot but once it gets out of that it drives fine and it really random when it dose it I replaced every thing electrical except the computer and it still dose it
You said you replaced the tps, did you adjust it properly? Mine does the same thing when it's running but since I am the only one who drives it I don't care. Check your grounds and look into c101(?) Removal would be where I would check after verifying tps is set right and tune up Parts are good.
Nick05 is offline  
post #10 of 13 Old 03-30-2017, 01:54 AM
cruiser54
Web Wheeler
 
cruiser54's Avatar
1990 MJ Comanche 
 
Join Date: Oct 2009
Location: Prescott
Posts: 12,025
Quote:
Originally Posted by Nick05 View Post
You said you replaced the tps, did you adjust it properly? Mine does the same thing when it's running but since I am the only one who drives it I don't care. Check your grounds and look into c101(?) Removal would be where I would check after verifying tps is set right and tune up Parts are good.
100% correct Nick.

If you own a Renix Jeep, you must check this out:


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


My Jeep technical photos:


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
cruiser54 is offline  
post #11 of 13 Old 03-31-2017, 07:23 AM Thread Starter
Wheels447
Registered User
1988 MJ Comanche 
 
Join Date: Jun 2016
Posts: 7
I don't know I probably did not adjust it right
Wheels447 is offline  
post #12 of 13 Old 03-31-2017, 08:04 AM
cruiser54
Web Wheeler
 
cruiser54's Avatar
1990 MJ Comanche 
 
Join Date: Oct 2009
Location: Prescott
Posts: 12,025
Quote:
Originally Posted by Wheels447 View Post
I don't know I probably did not adjust it right
http://cruiser54.com/?p=54

If you own a Renix Jeep, you must check this out:


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


My Jeep technical photos:


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
cruiser54 is offline  
post #13 of 13 Old 04-02-2017, 12:01 AM
Nick05
Registered User
1994 XJ Cherokee 
 
Join Date: Jan 2013
Posts: 708
Quote:
Originally Posted by cruiser54 View Post
Follow his advise. It has helped many jeepers
Nick05 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome