Slow acceleration, ACC/FCW, ESC warning - JeepForum.com
 
LinkBack Thread Tools
post #1 of 3 Old 12-11-2019, 07:36 PM Thread Starter
knut05
Registered User
 
Join Date: Dec 2019
Posts: 1
Slow acceleration, ACC/FCW, ESC warning

Hey all I am having some issues with my 2019 Cherokee. I drove to town tonight (about 20min) went into store. Came out started the Jeep and drove off as normal. About 10 seconds after I was driving I noticed it had VERRRY little response to the gas peddle being pushed. The RPMs would rise slightly but no power. That is problem 1. Problem 2 came shortly after that... The warning light system lit up! I had warning for "acc/fcw system disabled", electronic stability control disabled requires service" and "4x4 drive system disabled" all while I had no power to accelerate. I limped it home. I couldn't get above 55mph and even to reach that speed took a good minute (almost literally). This is the 2nd time in a month this has happened. Turned Jeep off and back on the first time this happened and all issues were cleared up but that didn't work this time. Will be taking to dealer tomorrow but wanted to see if anyone else has had similar problems.

knut05 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 12-12-2019, 12:20 PM
JeepCares
FCA Customer Care
 
JeepCares's Avatar
 
Join Date: Jan 2012
Location: MOPAR World Headquarters
Posts: 5,485
Quote:
Originally Posted by knut05 View Post
Hey all I am having some issues with my 2019 Cherokee. I drove to town tonight (about 20min) went into store. Came out started the Jeep and drove off as normal. About 10 seconds after I was driving I noticed it had VERRRY little response to the gas peddle being pushed. The RPMs would rise slightly but no power. That is problem 1. Problem 2 came shortly after that... The warning light system lit up! I had warning for "acc/fcw system disabled", electronic stability control disabled requires service" and "4x4 drive system disabled" all while I had no power to accelerate. I limped it home. I couldn't get above 55mph and even to reach that speed took a good minute (almost literally). This is the 2nd time in a month this has happened. Turned Jeep off and back on the first time this happened and all issues were cleared up but that didn't work this time. Will be taking to dealer tomorrow but wanted to see if anyone else has had similar problems.
Hello knut05,
We are certainly sorry to hear about your most recent concerns. Please keep us updated on how your appointment goes. If you experience continued troubles after you get your Cherokee back, well happily escalate a case on your behalf for further assistance.
Laura
JeepCares
JeepCares is online now  
post #3 of 3 Old 12-13-2019, 07:32 AM
browning
Registered User
2017 KL Cherokee 
 
Join Date: May 2009
Location: canada
Posts: 163
reading numerous posts for the JEEP CHEROKEE soft ware problems ..[1] Jeep does not care [service ] if they really cared they would recall all of their defective jeeps back from unsatisfied consumers . we paid a lot of hard earned money for a product the dealership can't fix or just don't care ..

bone collector
browning is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome