Battery issue - JeepForum.com
 
LinkBack Thread Tools
post #1 of 12 Old 04-04-2019, 10:53 AM Thread Starter
Redrac
Registered User
 
Join Date: Apr 2019
Posts: 7
Battery issue

My gf 2014 jeep Cherokee has been sitting with no battery for about 5 months now. I replaced the battery last Sunday and went to fire it up. Starts fine, but the engine idles at about 800 rpm. And when I press the throttle it goes to around 1100 rpm and drops back down. The check engine light is on and when I go to put it in drive or reverse it does not move. I'm at a complete loss. My theory is the ECU lost all memory from being dead for 5 month, but how am I able to get everything to relearn? Please helppp. I've started it everyday for 30 minutes and the same issues occur.

Redrac is offline  
Sponsored Links
Advertisement
 
post #2 of 12 Old 04-04-2019, 11:30 AM
jtec
Registered User
2014 JK Wrangler 
 
Join Date: Oct 2017
Posts: 5,635
easier said than done-
we need codes - a scanner is recommended.

Trans fluid - quantity? again a scanner is needed

As the trans are electric shift MAYBE check all fuses esp underhood.... look at #60 and #94

When I see the price of OEM I think aftermarket.
When I see the quality of aftermarket I think OEM.
jtec is offline  
post #3 of 12 Old 04-04-2019, 11:47 AM Thread Starter
Redrac
Registered User
 
Join Date: Apr 2019
Posts: 7
Thank you. I'm going to use a scan tool tomorrow and see what it pulls. Will also check fuses. It ran flawless before we let it sit. That's why I was dumbstruck when the MIL was lit. Will update post when I get codes.
Redrac is offline  
 
post #4 of 12 Old 04-04-2019, 12:23 PM
gotswap
Registered User
1989 YJ Wrangler 
 
Join Date: Dec 2013
Location: Peyton
Posts: 1,076
mice got to some wires?
gotswap is offline  
post #5 of 12 Old 04-05-2019, 08:18 AM Thread Starter
Redrac
Registered User
 
Join Date: Apr 2019
Posts: 7
Update to issue. Plugged scanner up. Codes P0610- Control module vehicle options error
P1500
U0140- lost comm with BCM.
All wires look good. Fuses are good as well.
Redrac is offline  
post #6 of 12 Old 04-05-2019, 09:35 AM
jtec
Registered User
2014 JK Wrangler 
 
Join Date: Oct 2017
Posts: 5,635
Looking over the list - first thought is there ANY changed electrical ie Audio, lighting, GPS?
Is there an accident history?
I would concentrate on TCM to start.
I will try to add a TCM wiring dia....TIME PERMITTING - work is expecting me to work...

P0610-00-ECU VEHICLE OPTIONS MISMATCH
Possible Causes
VIN VERIFICATION PROCEDURE NOT PERFORMED
USED CONTROLLER INSTALLED WITH WRONG CONFIGURATION
BODY CONTROL MODULE (BCM) NOT PROPERLY PROGRAMED OR WAS REPLACED AND NOT PROGRAMED
TRANSMISSION CONTROL MODULE (TCM) NOT PROPERLY PROGRAMED OR WAS REPLACED AND NOT PROGRAMED
TRANSMISSION CONTROL MODULE (TCM)
.................................................. .................................................. .............................
P1500-00-ECU CONFIGURATION MISMATCH
Possible Causes
USED CONTROLLER INSTALLED WITH WRONG CONFIGURATION
BCM NOT PROPERLY PROGRAMED OR WAS REPLACED AND NOT PROGRAMED
TCM NOT PROPERLY PROGRAMED OR WAS REPLACED AND NOT PROGRAMED
TRANSMISSION CONTROL MODULE (TCM)
.................................................. .................................................. .............................
U0140-00-LOST COMMUNICATION WITH BODY CONTROL MODULE
Possible Causes
CAN BUS CIRCUITS OPEN OR SHORTED
DTCS RELATED TO BATTERY VOLTAGE, IGNITION, OR VIN MESSAGES
BODY CONTROL MODULE POWER AND GROUND
BCM NOT CONFIGURED CORRECTLY
BODY CONTROL MODULE (BCM)
MODULE THAT SET THIS DTC

When I see the price of OEM I think aftermarket.
When I see the quality of aftermarket I think OEM.
jtec is offline  
post #7 of 12 Old 04-05-2019, 09:37 AM
jtec
Registered User
2014 JK Wrangler 
 
Join Date: Oct 2017
Posts: 5,635
confirm a 3.2L engine.

When I see the price of OEM I think aftermarket.
When I see the quality of aftermarket I think OEM.
jtec is offline  
post #8 of 12 Old 04-05-2019, 10:38 AM Thread Starter
Redrac
Registered User
 
Join Date: Apr 2019
Posts: 7
Yeah it's a 3.2 so really all the codes revolve around needing a reprogram on the ECU right?
Redrac is offline  
post #9 of 12 Old 04-05-2019, 10:45 AM Thread Starter
Redrac
Registered User
 
Join Date: Apr 2019
Posts: 7
Also. No prior accidents. All electronics work good. AC works and all the doors to the vents function. Today when I started it up I can do press throttle down and it will go up to about 3000 rpm and hold. But then drops to 800-900 once released.
Redrac is offline  
post #10 of 12 Old 04-05-2019, 11:45 AM Thread Starter
Redrac
Registered User
 
Join Date: Apr 2019
Posts: 7
Just kidding. Its a 2.4L
Redrac is offline  
post #11 of 12 Old 04-06-2019, 12:30 PM Thread Starter
Redrac
Registered User
 
Join Date: Apr 2019
Posts: 7
Ok update time. Vacuum hose to intake wasnt there for some reason. I Fixed that. Now it idles better and I can now put it in gear and drive. But.. when I put it in gear it is rough as fck. Like rocks the whole engine rough. When driving it doesnt shift.
Redrac is offline  
post #12 of 12 Old 04-07-2019, 08:24 AM
ForcedInduction
Registered User
2019 KL Cherokee 
 
Join Date: Aug 2018
Posts: 47
Time to gut up and take it to the dealer.


.

2019 Cherokee Limited
2.0 Hurricane
ForcedInduction is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
Charging Battery magik235 WK2 Grand Cherokee Forum 9 01-27-2019 12:46 PM
ESS Battery Type dprus WK2 Grand Cherokee Forum 1 11-27-2018 12:13 PM
Battery question JarheadAl Wrangler General Discussion 9 09-04-2018 12:16 PM
Door electrical issue Aero540t WJ Grand Cherokee Forum 0 07-21-2018 08:55 PM
Odd sputtering issue (long and kinda rambling but need help) Lkfool TJ Wrangler Technical Forum 10 12-29-2017 09:50 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome