2015 Cherokee "Christmas Tree" dash - JeepForum.com
 
LinkBack Thread Tools
post #1 of 2 Old 08-04-2020, 09:52 AM Thread Starter
shellyct
Registered User
 
Join Date: Aug 2020
Posts: 1
2015 Cherokee "Christmas Tree" dash

Just bought a used 2015 Cherokee with 39,000 miles on it to replace my '13 Comass, as the sucky CVT transmission was on its way out (along with other things). So I've had the car for 6 weeks, and the other day I parked the car, 20 minutes later left the store, went to start the car, and the whole dash lit up like a Christmas tree, "Service Transmission", "Service parking brake", engine light on, brake light on, eveyr light on the day. I thought "oh great, an electrical issue", I only have to get to 5 minutes up the road. Put it in Drive, and CLUNK! into drive. Alrighty then, not gonna drive it. CLUNK back into reverse to get back in the parking spot. Shut the car off. Turned it on again, same thing. rinse, repeat. Called my husband to come get me, took him 20 minutes. He put his computer on it, no codes. Started the car, and it was absolutely fine.

Just to add, it has had the "auto stop/start" error since I bought it. As I see others have said, the dealer said it has a second battery so I ignored it. My husband put the battery meter on it, and the battery is "supposedly" good. However, from what I've read on another thread, perhaps not? Although those other threads mention nothing about the Christmas Tree issue and transmission issue due to a low battery or bad cell? I have 2 weeks left on my used car warranty and its going in next week. But could it be just a battery? Or does it sound like there is another electrical problem going on?

The voltage is showing it charging, anywhere from 13.7 to 14.2 Sometimes it stays steady at 13.7, or 14. or 14.2 or whatever, but yesterday as i was driving a steady speed on a flat, level road the voltage was cycling up and down from 14. to 14.3, but it doesn't cycle upon acceleration or deceleration. From time to time, maybe every 4 or 5 days, when I press the start button it does sound a little slow to start, but its inconsistent and not related to how often I'm driving it. Still working from home here due to Covid, so I will go a day or two without driving, but that doesn't matter one bit. Even if I've driven in 2-4 days in a row it will still occasionally crank slowly.

I love the car, but damn, what I wouldn't give for something pre 1980's where diagnosis was a piece of cake!

Michelle

shellyct is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old 08-04-2020, 12:49 PM
GCWIMMER
Registered User
 
GCWIMMER's Avatar
 
Join Date: Jul 2014
Location: Reno
Posts: 126
First off the 2014 and up KL Cherokee don't have 2 batteries, Grand Cherokee's do. The 2015 and up with ESS are only getting 3/4 years at best from there AMG batteries. Take your 2015 Cherokee to one of the auto parts stores, most will do the test for free, and have it checked under load. I bet it's the battery and when you do replace it make sure it's the more expensive required AMG type. All new vehicles are so electrically sensitive they trigger warning lights for every thing else. Please check back when problem is solved for others looking for answers, good luck.

It's scary to think a Jeep dealer service department can't tell the difference between a KL Cherokee and Grand Cherokee, but you are not the first to be told that, unless you do have a Grand Cherokee.

2014 Bright White Limited 4X4 3.2 V6 - Build date 05/20/14 - Shark Fin antenna - Splash Guards
GCWIMMER is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome