WK does not accelerate over 1500 rpm - JeepForum.com
 
LinkBack Thread Tools
post #1 of 4 Old 09-25-2021, 11:10 AM Thread Starter
Trotineta
Registered User
 
Join Date: Sep 2021
Posts: 10
WK does not accelerate over 1500 rpm

I replace the actuator on my turbo. P0046 is gone but still no acceleration over 1500 rpm. Found the turbo intake hose broken. Could this be the issue? Could it be turbo issues( mechanical)? Do I need to reset the PCM and/ or ECU?

Trotineta is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 09-25-2021, 05:30 PM
Bigrigr
Registered User
 
Bigrigr's Avatar
2000 WJ 
 
Join Date: Jan 2020
Location: Near SLC
Posts: 2,664
Garage
Leaks in the turbo piping will definatley cause a loss of power. Repair the leak, and see what you get then....

'00LMTD-4.7l,242hd,D30,D44A,3.73's,True-trac front,Spartan rear,4" short arm lift,JK'sW/32's
Bigrigr is offline  
post #3 of 4 Old 09-25-2021, 07:48 PM Thread Starter
Trotineta
Registered User
 
Join Date: Sep 2021
Posts: 10
I will buy one Monday. The question is; how much damage a piece of broken gasket could do to the engine. If is it inside the turbo where could it go? Could intake blades cut it in pieces and push it in the engine? Did it burn? There is no axel movement on the intake side of the turbo
Trotineta is offline  
 
post #4 of 4 Old 09-25-2021, 08:26 PM
WJ60
Registered User
 
WJ60's Avatar
2001 WJ 
 
Join Date: Oct 2019
Location: Pasco
Posts: 1,032
Garage
You might get far more help in the WK forum.

'77 Chevy C10 pickup
'01 WJ 60th Anniversary Edition
'13 Dodge Dart Rallye
WJ60 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome