WJ fuel pump Howl…. - JeepForum.com
 1Likes
  • 1 Post By rjh41388
 
LinkBack Thread Tools
post #1 of 4 Old 10-16-2021, 08:27 PM Thread Starter
Jesaire55
Registered User
 
Join Date: Aug 2021
Posts: 2
WJ fuel pump Howl….

WJ enthusiasts,
Just replaced my failed electric fuel pump with a new one and I have a constant howl coming from the pump ( just loud enough to keep a gear head from thinking). Has anyone had this same issue? Any fixes?

I appreciate any feed back

Jesaire

Jesaire55 is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 10-16-2021, 10:34 PM
Soem0
Registered User
 
Soem0's Avatar
 
Join Date: Aug 2016
Posts: 645
That's just the hum of the pump. Was it a bosche unit? I hear many of the cheaper ones are loud af
Soem0 is offline  
post #3 of 4 Old 10-17-2021, 03:50 AM
rjh41388
Registered User
2004 WJ 
 
Join Date: May 2015
Location: Lansing
Posts: 28
Did you replace the filter too? Get under there and put your hand on the filter. I have a. 04 4.0. I got a mopar filter due to a long crank as the check valve in the filter failed and it made a horrendous howl immediately after replacement. It superseded to a new part number, which was much cheaper, I wonder why. I warrantied it twice and had the same howl. It got quieter the more throttle I gave it. I assume it’s the pressure regulator in the filter. I tried all kinds of things like securing to the bracket with hose clamps, wrapping it with foam and butyl tape, nothing worked. I worked at the dealer and decided to get with tech support as if it were a customers car and they basically said yea we have been having a rash of these have a nice day. Thanks guys that are supposed to help us figure out problems. I guess it’s too old of a vehicle and not enough filters are being sold for them to remedy this issue. I tried finding a new filter with the old original part number but no luck. Finally I got a duralast and it was quieter and seemed to have gone away as it wore in over the past 5 years, but I still hear it from time to time. Never touching the filter again. And 5 years later I see that it’s still the same part number.
CarlCarlsen likes this.
rjh41388 is offline  
 
post #4 of 4 Old 10-25-2021, 08:41 PM
CraigMBAx
Registered User
 
CraigMBAx's Avatar
 
Join Date: Feb 2019
Posts: 225
Garage
Quote:
I worked at the dealer and decided to get with tech support as if it were a customers car and they basically said yea we have been having a rash of these have a nice day.
Standard. lol.

1999 WJ Limted - Ex Soccer Mom ride turned Rule 25 Compliant Bike Hauler
CraigMBAx is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome