Will Overland rock sliders install on earlier models? - JeepForum.com
 
LinkBack Thread Tools
post #1 of 3 Old 07-30-2021, 02:54 PM Thread Starter
fhunziker
Registered User
2001 WJ 
 
Join Date: Feb 2016
Location: Richmond
Posts: 127
Will Overland rock sliders install on earlier models?

The Overland trim with rock sliders came out in 2002. Does anyone know if those rock sliders will bolt onto a 2001 Laredo without modification?


Sent from my iPhone using Tapatalk

fhunziker is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 07-30-2021, 08:07 PM
xcaliber81
Registered User
 
xcaliber81's Avatar
2004 WJ 
 
Join Date: Jul 2012
Location: Prince George
Posts: 5,409
Aparantly they will but you gotta drill all the mounting holes. A member here has done it.
xcaliber81 is offline  
post #3 of 3 Old 07-30-2021, 09:20 PM
sdg3205
Registered User
 
sdg3205's Avatar
2001 WJ 
 
Join Date: Jun 2011
Location: Surrey
Posts: 1,783
Iíve done it.

Yes, you need to be handy drilling some access hole and ideally be handy with a welder or fabricate mounting plates. Itís not ďplug and playĒ
sdg3205 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome