What is this and could it cause P0601!? - JeepForum.com
 
LinkBack Thread Tools
post #1 of 4 Old 07-16-2020, 08:27 AM Thread Starter
Frambo
Registered User
2004 WJ 
 
Join Date: Nov 2013
Location: London
Posts: 563
Hey all
Got a CEL and p0601 code. Whilst that usually means a bad Ecu, I removed the battery and tray over the weekend and when I checked just now I found this mystery sensor / plug / fuse / loose in the engine bay. Any ideas what it is and where it should go? I have a road trip tomorrow so would like to set off with peace of mind!

EDIT: I have since found out that this is the brake fluid level sensor and plugged it back in. Regarding the p0601, I appreciate that it seems to occur randomly but over the weekend I did accidentally reconnect my battery without reconnecting the ground pin on the fuse box. Could that be behind it? Seems doubtful though as the CEL and code only appeared today

It's on British driver's side if that helps

Cheers!

Attached Thumbnails
IMG_20200716_151658_1594909623463.jpg   IMG_20200716_151658_1594909643323.jpg  
Frambo is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 07-16-2020, 08:50 AM
jtec
Web Wheeler
 
jtec's Avatar
2014 JK Wrangler 
 
Join Date: Oct 2017
Posts: 8,480
thoughts:

what are the wire colours?
Give an idea the length of wire - it would reach air Intake, eng manifold, coolant bottle, etc?
Read codes (scanner) unplug sensor see if another code appears...

When I see the price of OEM I think aftermarket.
When I see the quality of aftermarket I think OEM.
jtec is offline  
post #3 of 4 Old 07-16-2020, 11:31 AM Thread Starter
Frambo
Registered User
2004 WJ 
 
Join Date: Nov 2013
Location: London
Posts: 563
Quote:
Originally Posted by jtec View Post
thoughts:

what are the wire colours?
Give an idea the length of wire - it would reach air Intake, eng manifold, coolant bottle, etc?
Read codes (scanner) unplug sensor see if another code appears...
Figured out it's the brake fluid level sensor but that doesn't explain the P0601!
Frambo is offline  
 
post #4 of 4 Old 07-16-2020, 01:35 PM
jtec
Web Wheeler
 
jtec's Avatar
2014 JK Wrangler 
 
Join Date: Oct 2017
Posts: 8,480
p0601 is an internal PCM issue.

When I see the price of OEM I think aftermarket.
When I see the quality of aftermarket I think OEM.
jtec is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome