I changed the valve cover gasket and screwed up my transmission - JeepForum.com
 4Likes
  • 4 Post By Ralph77
 
LinkBack Thread Tools
post #1 of 8 Old 04-01-2020, 02:27 PM Thread Starter
Purcell69
Registered User
2001 WJ 
 
Join Date: Apr 2010
Location: Oklahoma
Posts: 289
I changed the valve cover gasket and screwed up my transmission

I've been spending more that the usual amount on the Green Weenie trying to get ready for summer. Yesterday I got the AC vacuumed down and charged after replacing a damaged condenser core.

Today, I replaced the valve cover gasket and in the process, I broke the end off the kickdown/throttle valve cable. I have tried a few different methods to create a makeshift repair, but none will let the transmission shift in to top gear and at the same time, I noticed the cruise control will not set. It comes on on the dash display, but won't set.

How bad am I screwed?

-Joe

Purcell69 is offline  
Sponsored Links
Advertisement
 
post #2 of 8 Old 04-01-2020, 02:36 PM
Double E
Web Wheeler
 
Double E's Avatar
2004 WJ 
 
Join Date: Oct 2003
Location: Raleigh, NC
Posts: 6,243
Only until you can get to a junkyard or fab up a solution with JB weld.

'04 Freedom Edition HO & '04 Overland HO (previous '00 Laredo 4.7)
Double E is offline  
post #3 of 8 Old 04-01-2020, 03:37 PM Thread Starter
Purcell69
Registered User
2001 WJ 
 
Join Date: Apr 2010
Location: Oklahoma
Posts: 289
Cool. I was just looking at the bottom side of things. It doesn't look difficult to change out. I had it in my head that I'd need to open up the transmission to get to the bottom end of the cable. I can see that is not the case now. Thanks!

-Joe
Purcell69 is offline  
 
post #4 of 8 Old 04-02-2020, 12:06 AM
Ralph77
Registered User
2000 XJ Cherokee 
 
Join Date: Aug 2015
Posts: 2,802
In my travels I have come across this.
Not even sure if it is what you are talking about.
Apparently comes in different colors and metal I think.
So...........

https://www.shapeways.com/product/V9...tle-valve-clip
Ralph77 is offline  
post #5 of 8 Old 04-03-2020, 01:41 PM Thread Starter
Purcell69
Registered User
2001 WJ 
 
Join Date: Apr 2010
Location: Oklahoma
Posts: 289
Quote:
Originally Posted by Ralph77 View Post
In my travels I have come across this.
Not even sure if it is what you are talking about.
Apparently comes in different colors and metal I think.
So...........

https://www.shapeways.com/product/V9...tle-valve-clip
I saw one they make for the XJ Cherokee and started to order it, until I realized it was for the XJ.. I didn't find the one they make for the WJ and just ordered a new kickdown cable instead. I've been having issues with the transmission down shifts with the cruise control on anyway, so I ordered a solenoid kit and decided to do the whole shot at once.

That is great info for the next guy though, and the folks at Shapeways are wonderful. Like I said, I had ordered the wrong part, realized it after placing the order, and contacted them to cancel my order. They refunded my payment the following business day, no questions asked.

-Joe
Purcell69 is offline  
post #6 of 8 Old 04-03-2020, 01:47 PM
Ralph77
Registered User
2000 XJ Cherokee 
 
Join Date: Aug 2015
Posts: 2,802
Quote:
Originally Posted by Purcell69 View Post
I saw one they make for the XJ Cherokee and started to order it, until I realized it was for the XJ.. I didn't find the one they make for the WJ and just ordered a new kickdown cable instead. I've been having issues with the transmission down shifts with the cruise control on anyway, so I ordered a solenoid kit and decided to do the whole shot at once.

That is great info for the next guy though, and the folks at Shapeways are wonderful. Like I said, I had ordered the wrong part, realized it after placing the order, and contacted them to cancel my order. They refunded my payment the following business day, no questions asked.

-Joe
I have seen both and always wondered what the difference is.
Guessing that a 4.0 XJ throttle body would be the same as a WJ 4.0 throttle body but what do I know. LOL.
Ralph77 is offline  
post #7 of 8 Old 04-04-2020, 05:56 AM Thread Starter
Purcell69
Registered User
2001 WJ 
 
Join Date: Apr 2010
Location: Oklahoma
Posts: 289
Quote:
Originally Posted by Ralph77 View Post
I have seen both and always wondered what the difference is.
Guessing that a 4.0 XJ throttle body would be the same as a WJ 4.0 throttle body but what do I know. LOL.
The XJ specifies a shorter plastic body. I've got both vehicles so I can verify there is a difference. I'd just hate to wait a few weeks for one to be made, only to find out the difference IS important. Shapeways doesn't have a stockpile of these. They take orders and print them as needed. Of course, they print other items too, so it depends on where your order falls in line.

-Joe
Purcell69 is offline  
post #8 of 8 Old 04-08-2020, 03:44 PM Thread Starter
Purcell69
Registered User
2001 WJ 
 
Join Date: Apr 2010
Location: Oklahoma
Posts: 289
Well, I replaced the kickdown cable the other day, but it didn't fix the way the Jeep was running. I was having issues with the transmission not shifting in to overdrive and the torque converter not locking. Also, the cruise control would turn on, but would not engage.

As the sun fell, I found the cause. I was getting multiple Check Engine codes, (P0123, P0300, P0304, P0306 and P1494). I knew about the emissions code. I had a rotten elbow to the intake manifold that needed replaced, so I had capped the port until I could source a 1/4" replacement elbow. The misfires on cylinders 4 and 6 were new, but the engine was running smoothly, so I attributed those to old spark plugs the PO had installed who knows when.

The TPS fail code was the kicker. When I was messing with the throttle body, the cold air intake the previous owner had popped off. I didn't realize it had broken the TPS until the other night. The plug was hanging off the throttle body at a 45* angle. When I tried to move it, it broke completely.

With a new elbow, TPS, and fresh Champion Copper spark plugs, the Jeep was running great with no engine lights. Everything worked like it should and all was right with the world, until today.

That begins a new thread.

-Joe
Attached Thumbnails
IMG_6961.jpg   IMG_6962.jpg  
Purcell69 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome