Dead battery after = no idle? - JeepForum.com
 
LinkBack Thread Tools
post #1 of 9 Old 02-11-2019, 04:57 PM Thread Starter
xcaliber81
Registered User
 
xcaliber81's Avatar
2004 WJ 
 
Join Date: Jul 2012
Location: Prince George
Posts: 4,992
Dead battery after = no idle?

Battery kind of died after not being ran in 4 or 5 days in -20 to -40 temps.
I put a new battery in and it refused to idle for some time not so sure why that happened.

My guess in the battery was just too old and over the past few cold starts ive noticed harder starts I was wondering if my block heater wasnt working or the battery was just weak after the years.

Well It did idle after a while of me revving to 1000 rpm for a few mins.

Is this normal wj operation after having a dead battery?

xcaliber81 is offline  
Sponsored Links
Advertisement
 
post #2 of 9 Old 02-11-2019, 05:15 PM
Robinton
Registered User
 
Join Date: Oct 2005
Posts: 101
Garage
Most computer controlled vehicles can have driveability issues after a battery change until the computer relearns it's parameters.
Robinton is offline  
post #3 of 9 Old 02-11-2019, 07:24 PM Thread Starter
xcaliber81
Registered User
 
xcaliber81's Avatar
2004 WJ 
 
Join Date: Jul 2012
Location: Prince George
Posts: 4,992
I tested my block heater and at the end of the plug and its not working (I knew it), is this a chore to replace?
xcaliber81 is offline  
 
post #4 of 9 Old 02-11-2019, 09:22 PM
2oldjeeps
Registered User
2000 XJ Cherokee 
 
Join Date: Aug 2017
Posts: 1,704
Quote:
Well It did idle after a while of me revving to 1000 rpm for a few mins.

Is this normal wj operation after having a dead battery?

i have a 4.0 xj where i unhook batt for a few days. it does this when restarted.

99wj,143,000 miles
00xj,177,000 miles
10hummer3,74,000 miles
98xj,130,000 miles
2oldjeeps is offline  
post #5 of 9 Old 02-12-2019, 12:22 PM
frankjc
Registered User
1999 WJ 
 
Join Date: May 2013
Location: boston
Posts: 297
WJs don't like it when the battery gets run down. Mine did all kinds of strange things after it was parked for a while last summer.
frankjc is offline  
post #6 of 9 Old 02-12-2019, 04:45 PM
Dan_in_MN
Registered User
2000 WJ 
 
Join Date: May 2016
Posts: 411
Quote:
Originally Posted by xcaliber81 View Post
I tested my block heater and at the end of the plug and its not working (I knew it), is this a chore to replace?
4.0 or 4.7?

2000 WJ Grand Cherokee Black 236,000+ miles
Needs: Left rear wheel bearing. Front right CV joint.
Dan_in_MN is offline  
post #7 of 9 Old 02-13-2019, 08:43 AM Thread Starter
xcaliber81
Registered User
 
xcaliber81's Avatar
2004 WJ 
 
Join Date: Jul 2012
Location: Prince George
Posts: 4,992
Quote:
Originally Posted by Dan_in_MN View Post
4.0 or 4.7?
4.7 it's also listed in my specs.
xcaliber81 is offline  
post #8 of 9 Old 06-01-2020, 02:26 PM
Veronica01
Registered User
 
Join Date: May 2020
Posts: 2
[QUOTE=xcaliber81;40517733]Battery kind of died after not being ran in 4 or 5 days in -20 to -40 temps.
I put a new battery in and it refused to idle for some time not so sure why that happened.

My guess in the battery was just too old and over the past few cold starts ive noticed harder starts I was wondering if my block heater wasnt working or the battery was just weak after the years.

Well It did idle after a while of me revving to 1000 rpm for a few mins.

Is this normal wj operation after having a dead battery?

Seriously I just went through this. I charged battery and then it wouldn’t idle. I gave it gas and eventually started- but had it to do it each time I cranked it- i had tricked memory into thinking it needed those additional rpm to run- I unhooked cables let it sit 30 minutes.. hooked it back up. Turned ignition to start lights on dash - not fully cranked- waited 10 seconds- cranked and it reset memory! Runs great now.
Veronica01 is offline  
post #9 of 9 Old 06-01-2020, 11:28 PM Thread Starter
xcaliber81
Registered User
 
xcaliber81's Avatar
2004 WJ 
 
Join Date: Jul 2012
Location: Prince George
Posts: 4,992
My block heater was the culprit it gave up the fight right around when I made this post. I still haven't fixed it lol instead I put an oil pan heater and that oil pan heater all by itself made it through a -45 to -50 celcius cold snap for 4 days!
xcaliber81 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
12 Things You Can Do When Your ZJ Stalls ZeeJay1997 ZJ Grand Cherokee Forum 448 05-28-2019 07:14 PM
ZJ wouldn't start, problem was WEAK battery (PCM lost settings for fuel/air mixture) chimpanzee ZJ Grand Cherokee Forum 5 11-19-2018 03:10 PM
Dead short on battery positive Beechjeep WK Grand Cherokee & XK Commander Forum 2 06-20-2018 09:40 AM
New Badger build thread azzkicker WK Grand Cherokee & XK Commander Forum 10 06-18-2018 08:55 AM
How much driving to recharge a stone dead battery? Esmerda1125 ZJ Grand Cherokee Forum 7 03-15-2018 03:16 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome