Cooling fan help - JeepForum.com
 1Likes
Reply
 
LinkBack Thread Tools
post #1 of 17 Old 03-24-2019, 04:51 PM Thread Starter
Jamesgreen13
Registered User
2002 WJ 
 
Join Date: Jun 2017
Posts: 12
Cooling fan help

I have a 02 gc with the 4.7 v8 and my rad fan wont come on.

Recently i had done heads, timing set, all gaskets, etc due to overheating and warped a head on the highway etc etc.

The fans had worked before i removed them to do that job and now they don’t ..

They are connected and the ground on the fan is all intact. Ive tried to put direct power to the 12 wire on the fan plug and it never kicked the fan on high judt stayed on low.. so i was thinking solenoid issue but i don’t get a code for the soleniod. Maybe because the ecu/pcm only checks for the resistance from the solenoid? I was about to buy a used solenoid and see if it helps..

Any other advice before i go and buy a new/used solenoid lol?

Jamesgreen13 is offline  
Sponsored Links
Advertisement
 
post #2 of 17 Old 03-25-2019, 10:58 AM
jtpeters
Member
2004 WJ 
 
Join Date: Jun 2016
Location: Huntsville
Posts: 335
Garage
Not really my area of expertise, but do you have the hydraulic (power steering pump lines going to fan) driven fan?
If so, I believe you can check high fan speed by disconnecting the temp. gauge.
Someone please correct me if I am mistaken.

2004 Jeep Overland WJ 4.7 H.O. (Bought new in Oct 2003)
2014 Jeep Overland WK2 5.7 Hemi (Bought used in 2016 w/7k miles)
1970 Ford Mustang Boss 302 (in Family since 1974)
2013 Ford Mustang Boss 302
2011 BMW 328i
jtpeters is offline  
post #3 of 17 Old 03-25-2019, 12:43 PM
jtec
Registered User
2014 JK Wrangler 
 
Join Date: Oct 2017
Posts: 5,841
as mentioned this is a hydraulic fan, some rotation even if commanded off is expected, do as suggested and maybe engage AC and advise on fan operation. THe PS is operating ?

For codes you did use a SCANNER I am not sure the key on off will show the codes for this.

When I see the price of OEM I think aftermarket.
When I see the quality of aftermarket I think OEM.
jtec is offline  
 
post #4 of 17 Old 03-25-2019, 12:50 PM
paulvon
Registered User
 
Join Date: Jun 2018
Posts: 144
Here is my story and solution

https://www.jeepforum.com/forum/f310...1mqvTn6sQYCjhM

Sent using Tapatalk

1997 ZJ 4.0 L - Upgraded to heavy 93 sway bar
2004 WJ 4.7 L - 2 1/2" lift
2011 KK 3.7 L
paulvon is offline  
post #5 of 17 Old 03-26-2019, 05:28 AM Thread Starter
Jamesgreen13
Registered User
2002 WJ 
 
Join Date: Jun 2017
Posts: 12
Well i got home from work today and got the code for the fan solenoid being bad... p1499

Ill have to clear that to see if it comes back cause i didn’t reset codes since ive tried to force the fan on high mode.
Jamesgreen13 is offline  
post #6 of 17 Old 03-26-2019, 05:29 AM Thread Starter
Jamesgreen13
Registered User
2002 WJ 
 
Join Date: Jun 2017
Posts: 12
Paulvon when i tap the link it says not found buddy
Jamesgreen13 is offline  
post #7 of 17 Old 03-26-2019, 07:34 AM
paulvon
Registered User
 
Join Date: Jun 2018
Posts: 144
Not sure why the link did not work

Search for. " 4.7 Hydraulic Running Again" and paulvon. Then you should find it

Hope it helps

Sent using Tapatalk

1997 ZJ 4.0 L - Upgraded to heavy 93 sway bar
2004 WJ 4.7 L - 2 1/2" lift
2011 KK 3.7 L
paulvon is offline  
post #8 of 17 Old 03-26-2019, 07:58 AM
99sajeep
Registered User
 
99sajeep's Avatar
2005 WK 
 
Join Date: Jan 2009
Location: San Antonio
Posts: 602
4.7 hydraulic running again

'99 WJ 4x4 Ltd 4.7L (sold)
'05 WK 4x4 Ltd 5.7L (mine) 200k+ club
'01 WJ 4x4 Laredo 4.7L (daughter)
99sajeep is offline  
post #9 of 17 Old 03-27-2019, 06:07 AM Thread Starter
Jamesgreen13
Registered User
2002 WJ 
 
Join Date: Jun 2017
Posts: 12
Paulvon do you have a list of parts you used to add the filter? Im gonna give it a try.. and i cleared the code for the solenoid and it didn’t cone back it was cause i was testing it with direct power last weekend
Jamesgreen13 is offline  
post #10 of 17 Old 03-27-2019, 09:35 AM
paulvon
Registered User
 
Join Date: Jun 2018
Posts: 144
It was something like the Derale 13090 kit.

Make sure you use a filter for tranny fluid. Not sure how true but I have heard that coolant filters have an additional chemical in then that the tranny filters do not have.

I also added
2 elbows on the top of the filter housing
2 hose barb couplings
4 hose clamps
6 feet power steering hose

Sorry forgot the size off hand

Sent using Tapatalk

1997 ZJ 4.0 L - Upgraded to heavy 93 sway bar
2004 WJ 4.7 L - 2 1/2" lift
2011 KK 3.7 L
paulvon is offline  
post #11 of 17 Old 06-17-2019, 04:52 PM Thread Starter
Jamesgreen13
Registered User
2002 WJ 
 
Join Date: Jun 2017
Posts: 12
Well sorry for the really late update but i did install the inline filter a month or so ago and still have temps rise up the only way i have ever seen the fan on at full speed is when i unplug the coolant temp sensor... i havent let the “dirty” fluid out of the solenoid for quite a while so i’m kind of at a dead end the solenoid wants to work when i do unplug the sensor but not when the jeep is on the verge of over heating.. also i have been getting hotter than normal temps going uphill it gets to about 204-206 sometimes but when i pull a trailer with a couple of kayaks and stuff i see temps up to 217 easily with turning the heat on full blast to try to suffice.. i did remove my air shroud a while back and didn’t replace it ill see if that helps that issue..
Jamesgreen13 is offline  
post #12 of 17 Old 06-18-2019, 11:58 AM
99sajeep
Registered User
 
99sajeep's Avatar
2005 WK 
 
Join Date: Jan 2009
Location: San Antonio
Posts: 602
I would definitely put your fan shroud back on. The shroud is there so the air that the fan is pulling is forced thru the radiator. If it's not there, then the fan can pull some air from around the blades; that limits the amount of air coming thru the radiator.

What is the condition of your radiator? Has it been flushed? Any noticeable crud inside? How do the fins look? Any blockage thru the fins?
This could be contributing to the issue. Worth checking, if nothing else, to rule it out.

'99 WJ 4x4 Ltd 4.7L (sold)
'05 WK 4x4 Ltd 5.7L (mine) 200k+ club
'01 WJ 4x4 Laredo 4.7L (daughter)
99sajeep is offline  
post #13 of 17 Old 06-18-2019, 12:06 PM
FanTech
Registered User
 
Join Date: Jul 2018
Posts: 144
As a fan test technician, you absolutely NEED a shroud for a fan to work to it's full ability.
FanTech is offline  
post #14 of 17 Old 06-18-2019, 01:41 PM
paulvon
Registered User
 
Join Date: Jun 2018
Posts: 144
What happens when you turn on the a/c ?

Part of the logic is to increase fan speed with the a/c on.

Sent using Tapatalk

1997 ZJ 4.0 L - Upgraded to heavy 93 sway bar
2004 WJ 4.7 L - 2 1/2" lift
2011 KK 3.7 L
paulvon is offline  
post #15 of 17 Old 06-18-2019, 05:11 PM
leadsled jeep
Registered User
 
leadsled jeep's Avatar
2002 WJ 
 
Join Date: Sep 2006
Location: TriCities
Posts: 1,696
I use a turkey baster to pull out old power steered by fluid about 1/six months. I’ve heard these horror stories and try to keep mine fresh and clean. ~230k miles so far so good.
99sajeep likes this.

'02 Overland ~217k miles. OEM Engine/ Tranny. 2.5" Springs, All new control arms and Addco Sways.
leadsled jeep is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
My goal is to get 25+ mpg from my 99 XJ with 30 x 9.5 R15 ATs Charley3 XJ Cherokee Technical Forum 3853 02-12-2019 09:15 AM
'96 4.0 ZJ Cooling System Upgrades Hatsuwr ZJ Grand Cherokee Forum 11 10-15-2018 09:22 AM
WK Jeep GC Limited noisy hydraulic cooling fan Winston40 WK Grand Cherokee & XK Commander Forum 7 07-01-2018 08:01 AM
Radiator cooling fan motors wranglertec WJ Grand Cherokee Forum 14 05-13-2018 12:09 PM
Cooling fan troubleshooting XJ_jeepin_06 WK Grand Cherokee & XK Commander Forum 5 03-14-2018 12:19 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome