99 jeep 4.7 rough idle when stopped in drive - JeepForum.com
 
LinkBack Thread Tools
post #1 of 3 Old 04-19-2012, 07:31 PM Thread Starter
shawnsbruno
Registered User
1999 WJ 
 
Join Date: Apr 2012
Location: Altoona
Posts: 5
99 jeep 4.7 rough idle when stopped in drive

Hello Jeepsters my 99 grand cherokee limited when at operating temperature stopped in drive the idle goes from 750rpm to 400rpm or lower like its going to stall. Tried this in reverse and the rpm stays at 750. Replaced fuel filter, AIC motor, cleaned throttle body, oem spark plugs. Put on snapon computer, misfire #6 so I replaced coil. No more misfires, still the same problem. Could not find no more bad readings. Maybe the TPC? Any suggestions!!! Thanks

shawnsbruno is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 04-19-2012, 07:44 PM
dougy147
Registered User
 
dougy147's Avatar
2007 JK Wrangler 
 
Join Date: Jan 2005
Posts: 652
Hi there, welcome to the forum.

This post will probably be moved, because it really belongs in the tech section for your model. You're probably not going to get much for responses in this forum.

Second I think we need to sort out what you're jeep is. XJs didn't come with the 4.7. So you either have an XJ with a 4.0L inline 6, or a WJ Grand Cherokee with the 4.7 V8.

If you do have a WJ with the 4.7, I would pull the spark plug and see if it looks like there's been coolant burning in the chamber. The plug will look pretty clean compared to others and in my experience the electrode had a white "crackly" film on it, not something that looks like a powder which can be normal. I had this happen to me, started as a misfire and ended with a head replacement. Of course, it could be some other extremely simple thing.

The Past
95 ZJ Laredo 4.0
00 WJ Laredo 4.0 & 4.7
08 WK Laredo 4.7 (traded for tin can)
The Present
07 JK Unlimited Sahara
dougy147 is offline  
post #3 of 3 Old 04-19-2012, 07:54 PM Thread Starter
shawnsbruno
Registered User
1999 WJ 
 
Join Date: Apr 2012
Location: Altoona
Posts: 5
Thanks for the welcome. Plugs are burning excellent, runs like a beast when on the gas. Just bad when stopped in traffic.
shawnsbruno is offline  
Reply

Tags
4.7 liter , idle problems , jeep , rpm

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
Email updates stopped working? ajf1994 JeepForum Announcements 6 06-26-2011 09:29 AM
Rough Country RS9500 Winch Giveaway NOT FREE! cost $20 to Enter xsubarudude JeepForum Announcements 3 03-15-2011 05:03 PM
Rough Country mrblaine JeepForum Announcements 10 02-24-2009 08:38 AM
amount of idle time before log off mrcleanstj JeepForum Announcements 4 02-16-2009 08:45 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome