4WD Part Time Light - JeepForum.com
 
LinkBack Thread Tools
post #1 of 8 Old 08-03-2020, 10:11 AM Thread Starter
TastyWheatLoaf
Registered User
 
TastyWheatLoaf's Avatar
 
Join Date: Jun 2019
Posts: 102
Garage
4WD Part Time Light

Hey folks, random thing that has been happening to me. 03 4.0 with selec-trac. When doing long stints of around town driving, my part time light has been randomly lighting up on and off when stopped at lights. When on throttle it doesn't happen. Seems to happen when it's been hot out recently too. Any thoughts?

TastyWheatLoaf is offline  
Sponsored Links
Advertisement
 
post #2 of 8 Old 08-03-2020, 11:28 AM
DJCantonGA
Member
 
DJCantonGA's Avatar
2004 WJ 
 
Join Date: Mar 2018
Location: Canton
Posts: 371
Not sure on that one, but have you tried shifting it to PT/FT, then back up? Just to make sure it is fully engaged in 2WD. That is my only idea.

2004 WJ-4.0 I6-42RE-278K-2.5" BB-265/65/17 Toyo Open Country 2 AT-Quadratec Hardrock Wheels
DJCantonGA is offline  
post #3 of 8 Old 08-03-2020, 11:35 AM Thread Starter
TastyWheatLoaf
Registered User
 
TastyWheatLoaf's Avatar
 
Join Date: Jun 2019
Posts: 102
Garage
I'll give it a try, but yeah really weird. Like it only just started to happen and I've owned this jeep for 2+years now.
TastyWheatLoaf is offline  
 
post #4 of 8 Old 08-03-2020, 11:49 AM
DJCantonGA
Member
 
DJCantonGA's Avatar
2004 WJ 
 
Join Date: Mar 2018
Location: Canton
Posts: 371
Sometimes I'll have to shift back to 2wd, then back up for a few feet for it to fully disengage. Otherwise it will slip back into PT if I barely bump the shifter. Maybe it will work, who knows?

2004 WJ-4.0 I6-42RE-278K-2.5" BB-265/65/17 Toyo Open Country 2 AT-Quadratec Hardrock Wheels
DJCantonGA is offline  
post #5 of 8 Old 08-03-2020, 01:47 PM
Oktavius
Registered User
2004 WJ 
 
Join Date: Apr 2018
Posts: 512
Someone may be able to correct me, but I believe the switch on the transfer case has a plunger and a spring. Maybe the spring broke or the plunger isn't moving appropriately and causing the intermittent light to kick on randomly.
Oktavius is offline  
post #6 of 8 Old 08-03-2020, 02:03 PM
99wjtx
Registered User
 
99wjtx's Avatar
2001 WJ 
 
Join Date: Aug 2017
Posts: 666
Yes. Those sending units on the 242 are notoriously flakey from what I've read. I used to have the same problem with an intermittent light, which would come on sometimes when I was not in part time. I got irritated one day and crawled under the Jeep with a wire snip. No more light.

Rage! Rage against the dying of the Jeep.

99 WJ Limited 4.7/NV247
01 WJ Laredo 4.7/NP242
99wjtx is offline  
post #7 of 8 Old 08-03-2020, 02:17 PM
Oktavius
Registered User
2004 WJ 
 
Join Date: Apr 2018
Posts: 512
Quote:
Originally Posted by 99wjtx View Post
Yes. Those sending units on the 242 are notoriously flakey from what I've read. I used to have the same problem with an intermittent light, which would come on sometimes when I was not in part time. I got irritated one day and crawled under the Jeep with a wire snip. No more light.
I had swapped to the 242HD from a 247. I have the sensor there to plug the whole but did not see an unused plug on the wiring harness so it isn't hooked up. I also still have my QuadraDrive indicator plate on my shifter. Normally it is in Neutral which is really the 4 Full-Time, haha.
Oktavius is offline  
post #8 of 8 Old 08-03-2020, 05:15 PM
99wjtx
Registered User
 
99wjtx's Avatar
2001 WJ 
 
Join Date: Aug 2017
Posts: 666
Not that I recommend hooking it up, but there should be a short pigtail dangling off the harness at the top of the trans tunnel. It's obscured by tape or loom or both. I can't remember for sure but supposedly all WJs have it. I was able to find it on my '99 and '01.

There's an impossible to find jumper harness that goes between the sending unit and that trans tunnel harness. I didn't have the jumper harness so I spliced and diced, which might have contributed to the problems I was having. I know how to spice wires though so I'm leaning toward the sending unit itself being the problem.
Attached Thumbnails
242 wire jumper.jpg  

Rage! Rage against the dying of the Jeep.

99 WJ Limited 4.7/NV247
01 WJ Laredo 4.7/NP242
99wjtx is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome