2004 Jeep Grand Cherokee idling fast - JeepForum.com
 1Likes
  • 1 Post By jtec
 
LinkBack Thread Tools
post #1 of 6 Old 12-09-2019, 04:14 AM Thread Starter
Cincy71
Registered User
 
Join Date: Nov 2017
Posts: 6
2004 Jeep Grand Cherokee idling fast

I have a 2004 WJ that is idling fast. It is a 4.0. It doesn't idle fast when starting. Seems to be after driving for some time. Basically when it is running at normal temps. When I put it in neutral, it shoots ups between 1500 -2000 rpms. I can press the gas pedal one time and it goes back down to normal idle speeds.

I have replaced the TPS but it didn't help. Any suggestions what I should try next? Maybe IAC?

Cincy71 is offline  
Sponsored Links
Advertisement
 
post #2 of 6 Old 12-09-2019, 08:14 AM
jtec
Web Wheeler
 
jtec's Avatar
2014 JK Wrangler 
 
Join Date: Oct 2017
Posts: 7,027
Cheap and easy things first -

Check codes even if light is off.
Tell us is AIRBAG light on?
Cleaning the IAC is always recommended - tutorials on you tube.

let us know after those trying ideas.
Cincy71 likes this.

When I see the price of OEM I think aftermarket.
When I see the quality of aftermarket I think OEM.
jtec is online now  
post #3 of 6 Old 12-09-2019, 12:16 PM
2oldjeeps
Registered User
2000 XJ Cherokee 
 
Join Date: Aug 2017
Posts: 1,487
mine has done that,not enuf to bother,but it idles at 700,other jeeps at 4-500.
how can i move it down?

99wj,143,000 miles
00xj,177,000 miles
10hummer3,74,000 miles
98xj,130,000 miles
2oldjeeps is offline  
 
post #4 of 6 Old 12-10-2019, 09:41 PM
Waterluvr
Registered User
2004 WJ 
 
Join Date: Apr 2018
Location: South Bend, IN
Posts: 263
Garage
Quote:
Originally Posted by 2oldjeeps View Post
mine has done that,not enuf to bother,but it idles at 700,other jeeps at 4-500.
how can i move it down?
You can't, the pcm controls idle speed via 4 driver circuits to the IAC motor with a target value of 720 rpm's.
Waterluvr is online now  
post #5 of 6 Old 12-15-2019, 05:26 PM Thread Starter
Cincy71
Registered User
 
Join Date: Nov 2017
Posts: 6
No codes and airbag light isn't on.

I did clean the IAC though and it seems to have fixed the idling issue. It has been 4 days now since I cleaned the IAC and it hasn't idled fast since cleaning it.

Thanks for the suggestion Waterluvr. Hopefully that fixed the issue. If it starts again, I might just buy a new IAC. It looked pretty rough even after cleaning it.
Cincy71 is offline  
post #6 of 6 Old 12-15-2019, 05:29 PM Thread Starter
Cincy71
Registered User
 
Join Date: Nov 2017
Posts: 6
Thanks jtec for the suggestion.
Cincy71 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome