2002 Jeep WJ Laredo - Misfiring with codes. - JeepForum.com
 
LinkBack Thread Tools
post #1 of 13 Old 06-14-2019, 09:41 PM Thread Starter
Eds97ZJ
Registered User
 
Eds97ZJ's Avatar
1997 ZJ 
 
Join Date: Oct 2004
Location: Philly, PA
Posts: 161
2002 Jeep WJ Laredo - Misfiring with codes.

Hello, My jeep is a 02 WJ 4.0L. Misfire codes po300 - po302- po306.
It always misfires while driving n craws. I've learned that shutting it off n restarting it stops the misfiring. I then scan n clear the codes. It started about a month ago.

So I determined that it might be the coil pack so I bought a Delphi. Installed it n pulled all plugs checked them n gap. Everything seemed good but then it did it again but this time I only got the code for one cylinder po306. So far it's the only one that keeps recurring its been week. Anybody got any ideas? Thanks


1997 Jeep Grand Cherokee LMTD Loaded 5.2 V8 Q-Trac 4X4
Eds97ZJ is offline  
Sponsored Links
Advertisement
 
post #2 of 13 Old 06-16-2019, 12:05 AM Thread Starter
Eds97ZJ
Registered User
 
Eds97ZJ's Avatar
1997 ZJ 
 
Join Date: Oct 2004
Location: Philly, PA
Posts: 161
Hello? Can somebody help? I searched but couldn't find exactly my problem. Please help if you can.

I doubt this is related because I've had this problem for about 9 months now but just wanted to mention it.
The jeep also has 2 other codes po455 and po442. I know it's small n large evap leak and probably need a smoke tester to figure it out but if any of you know what hose or part it could be let me know. Thanks

1997 Jeep Grand Cherokee LMTD Loaded 5.2 V8 Q-Trac 4X4
Eds97ZJ is offline  
post #3 of 13 Old 06-16-2019, 09:43 AM
Mattyjm
Web Wheeler
 
Mattyjm's Avatar
2002 WJ 
 
Join Date: Dec 2014
Location: Butler, PA
Posts: 1,945
Garage
My number six cylinder on my 2004 4.0L WJ was misfiring. My mechanic advised me that he thought the coil rail was bad. I took the coil rail off to find Autolite Platinum Plugs underneath.

I immediately went and got a brand new set of NGK copper core plugs, gapped properly by myself and the AA tech and a new BWD coil rail from AA. I installed those, and have had NO misfire issues ever since, and that was a few years ago. It's my wife's DD, so I keep it in top shape.

2002 Laredo. Baloo.
2004 Rocky Mountain Edition. Froggy Bandit. Wife's Daily Driver. PRISTINE! Stock height and may stay that way.....
Mattyjm is offline  
 
post #4 of 13 Old 06-16-2019, 09:46 AM
jtec
Registered User
2014 JK Wrangler 
 
Join Date: Oct 2017
Posts: 5,857
explain " misfires while driving n craws." IDK?

only code you see is p0306?
what plugs are you using - solid core?
How did #6plug look compared to others? Wet, Black?
engine is STOCK, nothing added, modified?

A misfire can be ignition/spark, Fuel, or mechanical.
Lets try adding a can of 'seafoam' to fuel and while at auto part store have them scan your jeep - scans will get all codes - post all codes.

Next we would check compression BUT I suggest the ideas above first...

PS stop clearing codes a lot of data is lost. We may want to see that later.

When I see the price of OEM I think aftermarket.
When I see the quality of aftermarket I think OEM.
jtec is offline  
post #5 of 13 Old 06-16-2019, 11:11 AM Thread Starter
Eds97ZJ
Registered User
 
Eds97ZJ's Avatar
1997 ZJ 
 
Join Date: Oct 2004
Location: Philly, PA
Posts: 161
Hello guys, and thanks for replies.

Matt,
I replaced plugs last year when I bought it. I used recommended ngk's.
Like I said I replaced coil pack with a Delphi from rockauto n lost 1 code, the 302.

Jtec,
I mean it's only happened while driving not idling.
Does a lotta shaking. The cel would come on n blink. I could tell I was running on 4 cyl n then after replacing coil pack 5 cyl.

All plugs looked the same. Nice shape tan tips but toward porcelain they were black. Its all stock. Yes I also get the 455 442 codes cel comes on but doesnt blink for those.

BTW: It only has 119k on it. And just throwing this in it's a special edition.

1997 Jeep Grand Cherokee LMTD Loaded 5.2 V8 Q-Trac 4X4
Eds97ZJ is offline  
post #6 of 13 Old 06-16-2019, 11:17 AM Thread Starter
Eds97ZJ
Registered User
 
Eds97ZJ's Avatar
1997 ZJ 
 
Join Date: Oct 2004
Location: Philly, PA
Posts: 161
Forgot to mention, my scanner is a Innova $100 code reader. It also does live data. If you can tell me what to look for for bad numbers. I'll see what its showing n I'll take a pic of the screen.

1997 Jeep Grand Cherokee LMTD Loaded 5.2 V8 Q-Trac 4X4
Eds97ZJ is offline  
post #7 of 13 Old 06-16-2019, 11:26 AM Thread Starter
Eds97ZJ
Registered User
 
Eds97ZJ's Avatar
1997 ZJ 
 
Join Date: Oct 2004
Location: Philly, PA
Posts: 161
Under the hood but I made some better changes like getting rid of the broken fan shroud n new radiator n cap.
Attached Thumbnails
20180603_131511_1528046862959_1560705760851.jpg  

1997 Jeep Grand Cherokee LMTD Loaded 5.2 V8 Q-Trac 4X4
Eds97ZJ is offline  
post #8 of 13 Old 06-16-2019, 11:36 AM
jtec
Registered User
2014 JK Wrangler 
 
Join Date: Oct 2017
Posts: 5,857
the CEL blinking is an attention grabber, a priority as catalytic converter is likely if not corrected-

How does #6 plug look BLACK, WET? I would be nice to observe fuel pressure and pressure drop - sometimes easier said than done, jeep removed the schraider valve @ this year- let us know if there is a schraider valve on fuel rail.

Is there any issue starting jeep, does it take several cranks? or fires right off, might offer a clue to leak down comment.

Take a look at the purge solenoid vacuum lines for a leak, located by master cylinder,

looking at live data - ECT, o2 sensor voltages, fuel trims, MAP.

When I see the price of OEM I think aftermarket.
When I see the quality of aftermarket I think OEM.
jtec is offline  
post #9 of 13 Old 06-16-2019, 12:24 PM Thread Starter
Eds97ZJ
Registered User
 
Eds97ZJ's Avatar
1997 ZJ 
 
Join Date: Oct 2004
Location: Philly, PA
Posts: 161
Jtec,
Yeah, I know. Hope cc not ruined already.

Plugs are powder black.

I'll check for Schrader. I've looked before, I just dont remember. Getting old 😄

No problem starting.

Yeah already checked purge n hoses. Thought I had it fixed because I found 1 cracked hose at manifold but it didnt help except that it took more time to for cel to come on. Also tried another solenoid from 6cyl wj from junk yard but that made it worse not sure why.

Ok I'll look at all them. What's bad numbers on them vitals, or good numbers?

Just a little background on me. I'm a shade tree mechanic for years but I have a garage. So I know a lot about cars/trucks but I'm no tech. And i have tools but i they're craftsman a couple Mac's n a lotta harbor freight. How bout you?

1997 Jeep Grand Cherokee LMTD Loaded 5.2 V8 Q-Trac 4X4
Eds97ZJ is offline  
post #10 of 13 Old 06-16-2019, 01:48 PM
MrBaz
Registered User
2004 WJ 
 
Join Date: Dec 2007
Posts: 97
Quote:
Originally Posted by Eds97ZJ View Post
Jtec,
Yeah, I know. Hope cc not ruined already.

Plugs are powder black.

I'll check for Schrader. I've looked before, I just dont remember. Getting old 😄

No problem starting.

Yeah already checked purge n hoses. Thought I had it fixed because I found 1 cracked hose at manifold but it didnt help except that it took more time to for cel to come on. Also tried another solenoid from 6cyl wj from junk yard but that made it worse not sure why.

Ok I'll look at all them. What's bad numbers on them vitals, or good numbers?

Just a little background on me. I'm a shade tree mechanic for years but I have a garage. So I know a lot about cars/trucks but I'm no tech. And i have tools but i they're craftsman a couple Mac's n a lotta harbor freight. How bout you?
Sooty black all over (even the insulator)? Sounds like a rich condition. Leaky injector?

2004 WJ, 4.7HO, 2 cats, magnaflow
MrBaz is offline  
post #11 of 13 Old 06-16-2019, 04:04 PM
jtec
Registered User
2014 JK Wrangler 
 
Join Date: Oct 2017
Posts: 5,857
look at live data I suggested, ECT, O2 sensor voltage readings, fuel trims, and MAP, I would add TPS voltages -

TPS and MAP - if PCM thinks engine is going WOT enrichment will occur.. Also an exhaust system leak. Yoou corrected purge vac line issue?
With key on engine off slowlt open and close TPS - did voltage change smoothly both ways?

When I see the price of OEM I think aftermarket.
When I see the quality of aftermarket I think OEM.
jtec is offline  
post #12 of 13 Old 06-17-2019, 12:40 AM Thread Starter
Eds97ZJ
Registered User
 
Eds97ZJ's Avatar
1997 ZJ 
 
Join Date: Oct 2004
Location: Philly, PA
Posts: 161
Jtec,
Yeah inside soot black. Outside tan. No, evap leaks still occur. Not fixed.

1997 Jeep Grand Cherokee LMTD Loaded 5.2 V8 Q-Trac 4X4
Eds97ZJ is offline  
post #13 of 13 Old 06-17-2019, 09:46 PM Thread Starter
Eds97ZJ
Registered User
 
Eds97ZJ's Avatar
1997 ZJ 
 
Join Date: Oct 2004
Location: Philly, PA
Posts: 161
Ok, I'll try to get this info tomorrow.

Just adding this in here because its info I've picked up. Its possible it can also be crank ps n cam ps.

1997 Jeep Grand Cherokee LMTD Loaded 5.2 V8 Q-Trac 4X4
Eds97ZJ is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome