JeepForum.com

JeepForum.com (https://www.jeepforum.com/forum/)
-   WK2 Grand Cherokee Forum (https://www.jeepforum.com/forum/f309/)
-   -   WK2 3.6 Oil pump replacement (https://www.jeepforum.com/forum/f309/wk2-3-6-oil-pump-replacement-4379395/)

almoniyot 12-03-2019 03:40 AM

WK2 3.6 Oil pump replacement
 
Does anyone know roughly how many hours a shop would charge and what it entails? Thanks.

ColdCase 12-03-2019 08:44 AM

The pump runs off a chain off the crankshaft, where many others are run off a gear. Plenty of bolts, solenoids, and sprockets to deal with. The hardest part seems to be taking the oil pan off to get at the pump. By the book, that involves removing the front axle and half shafts (basically tearing apart the front suspension) along with steering gear.

almoniyot 12-19-2019 04:57 AM

So finally had the lifters/rocker arms changed and the ticking sound is gone. The mechanic screwed up something with the magnet on one of the camshafts and had to replace it (the camshaft position code wasn't showing before I brought the vehicle in). Now we are tackling P06DD. First we are going to try replacing the oil pressure sender unit (not easy to get to either). If that does not work, it will be the oil pump (fun!). The mechanic said they need to pull the engine to do this (guessing to avoid taking apart the suspension?). Is this true? Is it plausibly a 10 hour job?

almoniyot 12-19-2019 07:58 AM

Unfortunately the oil pressure sender unit did not cure the problem. So unfortunately it appears to be the oil pump. :crying2:

ColdCase 12-19-2019 08:53 AM

As far as I know its either pulling the engine or pulling the cradle, both are pretty big jobs. From scratch I would think pulling the cradle may be less work, or less chance of mistake, but that may just be me. You may want to ask them why they'd rather pull the engine than the cradle, we may learn something.

almoniyot 12-19-2019 10:25 AM

They apparently changed their mind, because now they say they and going to pull the cradle. It is a fairly time consuming job. I thought that with such a large engine compartment work should be easier, but I guess the 4wd system is in the way.

JackB1 12-19-2019 06:47 PM

I am surprised to hear an oil pump issue. Curious how many miles are on your WK?

almoniyot 12-20-2019 05:07 AM

Only 45,000 miles. One of the motor mounts needs to be replaced as well.

Bought the vehicle brand new. 2012 WK2 Laredo 4x4 3.6L. So far - Control arms, water pump 2x, roller rocker arms & lifters, oil pressure sender, oil pump, motor mount. Maybe this one was made on a Monday morning?

ColdCase 12-20-2019 07:51 AM

Except for the engine mount and control arm, it sounds like the effects of debris in the oil gallery, either left over from the manufacturing process, or from the valve train component failure, or perhaps overheating. Perhaps gummed up oil. Has it been in an accident? Nothing but good quality oil used and changed regularly? Did it spend a lot of time idling?

Then it may just be one of those random events.

almoniyot 12-20-2019 09:31 AM

Since purchased new I have serviced the vehicle at a garage authorized by the FCA importer according to the recommended service intervals. Never been in an accident. It is possible they cut corners and used low quality oil. It wouldn't shock me. In the past I purchased a Skoda (Czech VW) used and the engine (1.8T) was full of sludge due to the use of incorrect oil. If I hadn't caught it on time the engine could have seized. They have already dropped the suspension and I will stop by after the weekend to see how things look when the oil pan is removed.

mickey53usa 04-21-2020 06:28 PM

I just had the oil pressure sending unit, Oil Cooler and Oil filter housing replaced due to the constant P06DD code. Less then six miles of driving and I get the code again. I had the items replaced by a third party shop that I trust completely. 2012 WK2, purchased new, 50,844 miles. I guess the next step is oil pump??

almoniyot 04-22-2020 03:32 PM

Seemed to have fixed my problem. A lot of labor involved.

JackB1 04-24-2020 08:24 AM

So what was your final cost?

mickey53usa 04-25-2020 08:04 AM

My independent shop quoted me $800 labor. Parts are about $200 - so a grand - they have never done an oil pump on this model of Jeep so they are a little hesitant. They suggested clearing the code and trading - but since mine is setup to tow behind my Motor Home, it brings up a whole set of other problems. Besides, if I trade, I get a new oil pump. Nothing else wrong with mine - So, which way do I go, car payments again - or fix what I have ---

emacca 04-25-2020 03:43 PM

So the equal of two car payments to fix yours plus some inconvenience , or car payments for years

No brainer in my opinion


The time now is 08:16 AM.

Powered by vBulletin Version 3.8.8
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.

User Alert System provided by Advanced User Tagging (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.