Push Start Stalling Out - JeepForum.com
 
LinkBack Thread Tools
post #1 of 15 Old 08-19-2019, 03:14 PM Thread Starter
muzicman82
Registered User
2011 WK 
 
Join Date: Jan 2004
Location: Bear, DE
Posts: 278
Push Start Stalling Out

Hi all, my 2011 Laredo has stalled out immediately after starting about 1/5 times immediately after starting it, probably since I got the thing. It will always start right up on the 2nd try.. And I'm sure it isn't a battery thing. What else should I be looking at? It does it the most when it is cold.

Sent from my SM-G950U using Tapatalk


2011 Jeep Grand Cherokee Laredo - 3.6L V6
158,000 (10/2018)

1996 Jeep Grand Cherokee Limited - 5.2L V8
366,700 miles (4/21/12) (Laid to rest, but worked)
muzicman82 is offline  
Sponsored Links
Advertisement
 
post #2 of 15 Old 08-19-2019, 04:27 PM
Bilko
Registered User
 
Join Date: Nov 2018
Posts: 54
It sounds like the same problem i had on my 2012 Is your check engine light on?

https://www.jeepforum.com/forum/f309...p0572-4332905/
Bilko is offline  
post #3 of 15 Old 08-21-2019, 06:53 PM Thread Starter
muzicman82
Registered User
2011 WK 
 
Join Date: Jan 2004
Location: Bear, DE
Posts: 278
Quote:
Originally Posted by Bilko View Post
It sounds like the same problem i had on my 2012 Is your check engine light on?

https://www.jeepforum.com/forum/f309...p0572-4332905/
No it isn't on.. and I have a ScanTool and no codes are there. I've had the vehicle for 6+ years and it has always done it from time to time. I did replace the battery a couple years ago and it did it on that brand new.

2011 Jeep Grand Cherokee Laredo - 3.6L V6
158,000 (10/2018)

1996 Jeep Grand Cherokee Limited - 5.2L V8
366,700 miles (4/21/12) (Laid to rest, but worked)
muzicman82 is offline  
 
post #4 of 15 Old 08-21-2019, 09:41 PM
ColdCase
My Reality Check Bounced
 
ColdCase's Avatar
2011 WK 
 
Join Date: Sep 2009
Location: New England
Posts: 13,989
Check/replace the brake switch. It usually doesn't throw a code, or at least one you can read with the typical OBD scanner.

Some people think I'm stupid and I totally disagree. But my biggest fear is that me thinking I'm smart proves them right.....
Current: 2011 Grand Cherokee Overland V8, 2009 Liberty Rocky Mt V6
Previous: 2000 Grand Cherokee Laredo I6, 1979 CJ7 I6 Quadratrac
ColdCase is online now  
post #5 of 15 Old 08-22-2019, 05:19 PM Thread Starter
muzicman82
Registered User
2011 WK 
 
Join Date: Jan 2004
Location: Bear, DE
Posts: 278
Quote:
Originally Posted by ColdCase View Post
Check/replace the brake switch. It usually doesn't throw a code, or at least one you can read with the typical OBD scanner.
Wouldn't I have other issues if this was the issue? Like brake lights and the vehicle not starting at all?

Sent from my SM-G950U using Tapatalk

2011 Jeep Grand Cherokee Laredo - 3.6L V6
158,000 (10/2018)

1996 Jeep Grand Cherokee Limited - 5.2L V8
366,700 miles (4/21/12) (Laid to rest, but worked)
muzicman82 is offline  
post #6 of 15 Old 08-22-2019, 05:57 PM
ColdCase
My Reality Check Bounced
 
ColdCase's Avatar
2011 WK 
 
Join Date: Sep 2009
Location: New England
Posts: 13,989
Its a multi contact switch, one contact feeds the brake lights, another contact feed the cruise control and start.

No guarantees, but its a inexpensive fix thats worked for some.

Some people think I'm stupid and I totally disagree. But my biggest fear is that me thinking I'm smart proves them right.....
Current: 2011 Grand Cherokee Overland V8, 2009 Liberty Rocky Mt V6
Previous: 2000 Grand Cherokee Laredo I6, 1979 CJ7 I6 Quadratrac
ColdCase is online now  
post #7 of 15 Old 08-23-2019, 07:59 AM
Jlow28
Registered User
 
Join Date: Aug 2018
Posts: 9
You checked the fuel pump relay? After the recall on my 13, I had to order a new external relay recently after a start / stall. Interesting information on the brake stop switch.


Sent from my iPhone using Tapatalk Pro
Jlow28 is offline  
post #8 of 15 Old 08-26-2019, 12:14 PM
madmaxwell87
Registered User
2012 WK 
 
Join Date: Oct 2012
Location: SF Bay Area
Posts: 35
Garage
Quote:
Originally Posted by Jlow28 View Post
You checked the fuel pump relay? After the recall on my 13, I had to order a new external relay recently after a start / stall. Interesting information on the brake stop switch.
I replaced this to try to solve this issue for my 12 Overland Hemi and it is still doing it. If you only use the remote start it is never an issue. I have heard it could be the TPIM which is a big and expensive job. Hadn't heard about the brake light switch so I'll look into that too.

Red 12 WK2 Overland 5.7L. 18x9 Procomp Rockwell and 265/65/18 BFG AT
madmaxwell87 is offline  
post #9 of 15 Old 08-26-2019, 04:23 PM
Bilko
Registered User
 
Join Date: Nov 2018
Posts: 54
if its the brake light switch you may also find you can start the engine without pressing the break pedal
Bilko is offline  
post #10 of 15 Old 08-27-2019, 08:53 AM Thread Starter
muzicman82
Registered User
2011 WK 
 
Join Date: Jan 2004
Location: Bear, DE
Posts: 278
I don't have remote start and I have never been able to start it without pressing the brake pedal.

2011 Jeep Grand Cherokee Laredo - 3.6L V6
158,000 (10/2018)

1996 Jeep Grand Cherokee Limited - 5.2L V8
366,700 miles (4/21/12) (Laid to rest, but worked)
muzicman82 is offline  
post #11 of 15 Old 08-28-2019, 10:40 AM
Bilko
Registered User
 
Join Date: Nov 2018
Posts: 54
Have you had the fuel pump relay recall done? It was recall P54. If so it's worth changing the relay, they are only a few dollars and easy to do.
Bilko is offline  
post #12 of 15 Old 08-31-2019, 04:33 PM Thread Starter
muzicman82
Registered User
2011 WK 
 
Join Date: Jan 2004
Location: Bear, DE
Posts: 278
As far as I know, all recalls were taken care of about a year ago with the dealer.

Sent from my SM-G950U using Tapatalk

2011 Jeep Grand Cherokee Laredo - 3.6L V6
158,000 (10/2018)

1996 Jeep Grand Cherokee Limited - 5.2L V8
366,700 miles (4/21/12) (Laid to rest, but worked)
muzicman82 is offline  
post #13 of 15 Old 08-31-2019, 06:00 PM
ColdCase
My Reality Check Bounced
 
ColdCase's Avatar
2011 WK 
 
Join Date: Sep 2009
Location: New England
Posts: 13,989
The relay they install via the recall doesn’t seem to be durable. Its easy and cheap to replace, may solve your issue. There is a thread around here somewhere with relay suggestions.

Some people think I'm stupid and I totally disagree. But my biggest fear is that me thinking I'm smart proves them right.....
Current: 2011 Grand Cherokee Overland V8, 2009 Liberty Rocky Mt V6
Previous: 2000 Grand Cherokee Laredo I6, 1979 CJ7 I6 Quadratrac
ColdCase is online now  
post #14 of 15 Old 09-02-2019, 04:43 AM
GPV1
Registered User
 
GPV1's Avatar
2012 WK 
 
Join Date: Dec 2011
Posts: 146
Having the same issue on my 2012. It's very intermittent and usually on a warm restart, it will fire just fine then start running very rough and stall after a few seconds. Restarting solves the issue. I picked up a new fuel pump relay and will try that, my dealer replaced the brake switch about 15,000 miles ago while troubleshooting an unrelated issue so I'm ruling that out for now.
GPV1 is offline  
post #15 of 15 Old 09-04-2019, 11:06 AM
=KZ=
Registered User
2000 WJ 
 
Join Date: Jun 2005
Location: Victoria, BC Canada
Posts: 1,224
I have the same problem with push start, but no problems at all using the key. Are you supposed to have to put your foot on the brake to start with the key? Mine starts with the key without touching the brake.
=KZ= is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome