Fuel pump relay replaced by dealer, still no bueno - JeepForum.com
 
LinkBack Thread Tools
post #1 of 12 Old 05-20-2020, 06:44 AM Thread Starter
SeaVee
Registered User
 
Join Date: Oct 2017
Posts: 12
Fuel pump relay replaced by dealer, still no bueno

2012 GC 5.7, 108k. Daughter’s car, here’s the description we gave Service Mgr at local Jeep dealership:
Car Issues

Turns on, immediately the engine turns off and gets stuck in whatever gear i am in. so if i’m in drive or reverse it keeps going and the brakes lock up and i can’t stop. if i am in park, it won’t let me turn it off, it just tries to start again and will try to start for about 10/20 seconds but won’t turn over. none of the buttons work while this is happening i can’t stop it and it usually just gives up after about 20/30 seconds. weird stuff blows through the vent smells like stuff is burning. this will happen usually about 4-5 times before i can get it to start and run successfully. if it starts and doesn’t do the thing it’ll shake pretty bad for a few minutes and then either turn off or stop shaking and be fine. something stuck in my AC vents on driver side the air usually only comes out of the bottom corner.

We sent two quick video clips of the instrument panel freaking out but I can’t seem to post them.

No reply from dealer so looking for advice, I have searched all the threads related to this issue and doesn’t seem to be any definitive answer. The car is unsafe.

SeaVee is offline  
Sponsored Links
Advertisement
 
post #2 of 12 Old 05-20-2020, 11:49 AM
ColdCase
My Reality Check Bounced
 
ColdCase's Avatar
2011 WK 
 
Join Date: Sep 2009
Location: New England
Posts: 15,518
Almost sounds like a transmission or PCM issue (the PCM controls the transmission). The 2012 is not shift by wire, there is a cable from the shifter to the transmission, so you should be able to move to/from any gear except park unless there is an internal problem or the PCM is wakey. If it fails in a mode where the clutches are working against each other , strange things can happen.

You should be able to stop regardless, but when the engine is stalled you loose vacuum assist so its going to take more effort.

There is a thread around here somewhere about jeeps not stopping. If no one jumps in here by the time I get back, I'll try to find it. Don't recall the resolution.

The blend door gear thread indexed in the maintenance sticky thread may give you a clue about the air flow. I'm thinking the foul swell is exhaust or other fumes being pulled in from outside.

You probably won't be able to post video until you've had 10 posts.

There have been a few bad fuel pumps being reported, but that doesn't sound like the entire story.

Do not mistake temptation for opportunity
Current: 2011 Grand Cherokee Overland V8, 2009 Liberty Rocky Mt V6
Previous: 2000 Grand Cherokee Laredo I6, 1979 CJ7 I6 Quadratrac
ColdCase is offline  
post #3 of 12 Old 05-20-2020, 12:11 PM Thread Starter
SeaVee
Registered User
 
Join Date: Oct 2017
Posts: 12
The smell, and I have smelled it, is electrical smelling. Sometimes it seems like the fuel pump seems to keep running even when engine is off. And the way it continues to crank when you’re not pressing the start button is weird. Let me try to post pics again, I’ve got 10+ posts, I’m over on the XJ side as I have a cream puff 2001 XJ that I’m quite the fan of. I wish I could feel that way about this WK2.
SeaVee is offline  
 
post #4 of 12 Old 05-20-2020, 08:34 PM
ColdCase
My Reality Check Bounced
 
ColdCase's Avatar
2011 WK 
 
Join Date: Sep 2009
Location: New England
Posts: 15,518
It is a TIP start, it will crank until started or for 5-10 seconds.

Its normal for the fuel pump to run a bit after shut down.

You may have a blower motor overheating.

Are you quick enough to put it in gear before the engine immediately turns off?

What do you mean by trying to start and won't turn over?

Sounds like you may have a hard starting problem. You may have to look at live OBD data, check for vacuum leaks (brake booster check valve), measure fuel pressure and compression/leak down, check spark plugs, 2012s need them changed every 30,000 miles or so. Bunch of things.

Some related discussion in this thread I think:

https://www.jeepforum.com/forum/f309...-gear-4393351/

Do not mistake temptation for opportunity
Current: 2011 Grand Cherokee Overland V8, 2009 Liberty Rocky Mt V6
Previous: 2000 Grand Cherokee Laredo I6, 1979 CJ7 I6 Quadratrac
ColdCase is offline  
post #5 of 12 Old 05-21-2020, 09:34 AM Thread Starter
SeaVee
Registered User
 
Join Date: Oct 2017
Posts: 12
Cold case- Thanks for all the info. Since it’s my daughters, I have to depend on her recollections of the issue, since it’s so random.
The electrical smell is only around when all the no start, crazy dashboard issues occur, never smells otherwise. I assume the dealer ran an OBS, they came back with $885.00 worth of recommendations, stupid stuff like fuel systems treatment at 150, diff service for 190! This thing has 108 k on it and it had the major dealer service at 96k- might have to find another dealer
SeaVee is offline  
post #6 of 12 Old 05-21-2020, 10:31 AM
ColdCase
My Reality Check Bounced
 
ColdCase's Avatar
2011 WK 
 
Join Date: Sep 2009
Location: New England
Posts: 15,518
Quote:
Originally Posted by SeaVee View Post
Since itís my daughters, I have to depend on her recollections of the issue,

Been there x 4, thats a tough one to navigate, ....

Do not mistake temptation for opportunity
Current: 2011 Grand Cherokee Overland V8, 2009 Liberty Rocky Mt V6
Previous: 2000 Grand Cherokee Laredo I6, 1979 CJ7 I6 Quadratrac
ColdCase is offline  
post #7 of 12 Old 05-22-2020, 12:06 PM
JeepCares
FCA Customer Care
 
JeepCares's Avatar
 
Join Date: Jan 2012
Location: MOPAR World Headquarters
Posts: 5,614
Quote:
Originally Posted by SeaVee View Post
2012 GC 5.7, 108k. Daughterís car, hereís the description we gave Service Mgr at local Jeep dealership:
Car Issues

Turns on, immediately the engine turns off and gets stuck in whatever gear i am in. so if iím in drive or reverse it keeps going and the brakes lock up and i canít stop. if i am in park, it wonít let me turn it off, it just tries to start again and will try to start for about 10/20 seconds but wonít turn over. none of the buttons work while this is happening i canít stop it and it usually just gives up after about 20/30 seconds. weird stuff blows through the vent smells like stuff is burning. this will happen usually about 4-5 times before i can get it to start and run successfully. if it starts and doesnít do the thing itíll shake pretty bad for a few minutes and then either turn off or stop shaking and be fine. something stuck in my AC vents on driver side the air usually only comes out of the bottom corner.

We sent two quick video clips of the instrument panel freaking out but I canít seem to post them.

No reply from dealer so looking for advice, I have searched all the threads related to this issue and doesnít seem to be any definitive answer. The car is unsafe.
We're sorry to hear about your experience with the dealer. If your daughter would like any additional assistance while working with the dealer, please have her reach out to us here or call 1-877-426-5337 for additional assistance.
Alex
Jeep Cares
JeepCares is online now  
post #8 of 12 Old 05-23-2020, 01:21 PM
BigTizzie
Registered User
 
BigTizzie's Avatar
2011 WK 
 
Join Date: Jun 2016
Location: Moneyapolis, MN
Posts: 546


OK, this is a weird one. Battery or wiring problems?
BigTizzie is offline  
post #9 of 12 Old 05-26-2020, 07:10 AM Thread Starter
SeaVee
Registered User
 
Join Date: Oct 2017
Posts: 12
Battery is about 6 months old, think I’ll take a look at the batt connections just to be sure. Thanks for all the replies
SeaVee is offline  
post #10 of 12 Old 05-26-2020, 03:01 PM
Wranglerwild098
Registered User
 
Join Date: Mar 2018
Posts: 13
Quote:
Originally Posted by SeaVee View Post
Battery is about 6 months old, think I’ll take a look at the batt connections just to be sure. Thanks for all the replies
Sorry to hear about this, but unfortunately it’s what these vehicles do. 2011-2014 I heard in compass at new as 2018.

It’s the computer. Jeep has had this issue for a long time and the dealer won’t recognize it. These issues never throw a code so the dealer can’t “figure it out.” They came out with some recalls that said would fix these type of issues, but they do not.

I have a 2011 that does the mysterious shutoff will slowing down and slightly turning. I did absolutely everything that everyone said was the issue. 4 years last still does it. The trick for that was to drive it in MANUAL (“separate” computer from automatic”).

The issue you Are having I also have this occasionally... happens maybe once or twice a month. I notice my gas tank is always low when it does. You can always kill it by shutting the ignition off. The vehicle can not operate if it’s not on.

The only thing I haven’t done was spend the $2k to replace the “motherboard.” Best bet trade it or sell it ... I don’t let anyone else drive my vehicle because of these “unexplainable mysterious problems.” Or the best one I got was “you must not be seeing or hearing it that way...” lol
Wranglerwild098 is offline  
post #11 of 12 Old Yesterday, 09:19 AM Thread Starter
SeaVee
Registered User
 
Join Date: Oct 2017
Posts: 12
What year did they correct this problem? Are you referring to the TPIM when you say “Motherboard “. Thanks,SeaVee
SeaVee is offline  
post #12 of 12 Old Yesterday, 11:36 AM
ColdCase
My Reality Check Bounced
 
ColdCase's Avatar
2011 WK 
 
Join Date: Sep 2009
Location: New England
Posts: 15,518
I don't think they ever corrected the problem entirely, but the TIPM was revised in 2014 I think.

Do not mistake temptation for opportunity
Current: 2011 Grand Cherokee Overland V8, 2009 Liberty Rocky Mt V6
Previous: 2000 Grand Cherokee Laredo I6, 1979 CJ7 I6 Quadratrac
ColdCase is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome