Flashing engine light? - JeepForum.com
 
LinkBack Thread Tools
post #1 of 9 Old 10-07-2021, 12:00 PM Thread Starter
dtrkyman
Registered User
2013 WK 
 
Join Date: Feb 2012
Location: Santa Fe
Posts: 445
Flashing engine light?

Zero symptoms prior, turned off jeep for 10 minutes or so was running driving normal…get back in power comes on but will not even turn over, engine light flashing.

Any ideas?


Sent from my iPhone using Tapatalk

dtrkyman is offline  
Sponsored Links
Advertisement
 
post #2 of 9 Old 10-07-2021, 02:23 PM
jtec
Registered User
 
jtec's Avatar
2014 JK Wrangler 
 
Join Date: Oct 2017
Posts: 10,654
flashing VEL is an attention geter - Cat damage is likely, often an fuel inj or ign issue.


Are the other warning light flashing at start attempt ABS, SRS?

When I see the price of OEM I think aftermarket.
When I see the quality of aftermarket I think OEM.
jtec is online now  
post #3 of 9 Old 10-07-2021, 02:40 PM Thread Starter
dtrkyman
Registered User
2013 WK 
 
Join Date: Feb 2012
Location: Santa Fe
Posts: 445
Seems like the starter…tried it and it squealed like a pig…tried again started up and sounded like stater was still engaged.

Couple whacks it stopped .

Engine light off everything else normal.


Sent from my iPhone using Tapatalk
dtrkyman is offline  
 
post #4 of 9 Old 10-09-2021, 01:32 PM Thread Starter
dtrkyman
Registered User
2013 WK 
 
Join Date: Feb 2012
Location: Santa Fe
Posts: 445
No go after starter replacement…just clicks once and nothing happens. Same as before. Electrical issue somewhere?


Sent from my iPhone using Tapatalk
dtrkyman is offline  
post #5 of 9 Old 10-09-2021, 02:07 PM
ColdCase
My Reality Check Bounced
 
ColdCase's Avatar
2011 WK 
 
Join Date: Sep 2009
Location: New England
Posts: 18,314
Are you hearing the starter solenoid click or the starter relay (TIMP). Does the engine turn freely? How good is the battery, are its cables tight? Is the battery and engine ground connection OK?

Did you get the DTC codes read, any in the history?

There have been reports that the switch that detects neutral or park can be defective and inhibit starting. I dnn't think you would here the starter solenoid or relay click, however.

Starter Relay Operation

In a no crank condition the Starter Relay can be missing power at pin 85, feed at pin 30, controlled ground at pin 86 or output at pin 87. Further explanation of how a relay operates is listed below.

•Pin 85 receives power from the TIPM once the parameters for the Ignition Switch position and status, and all inhibit monitors (i.e. clutch switch, RPM, etc.) are satisfied.
•Pin 30 is a constant B+ feed.
•Pin 86 is a controlled ground by a module (i.e. PCM or BCM). Once power is sent from the TIPM to the pin 85 of the relay it passes through a coil and leaves the relay through pin 86 to control module.
•Pin 87 is an output circuit to the Starter solenoid. Once the circuit on pin 86 is grounded by the control module, the coil winding in the relay magnetically pulls the internal switch closed. When the internal switch is closed the power at pin 30 is sent to pin 87 of the relay.

I just got lost in thought. It was unfamiliar territory;
Current: 2011 Grand Cherokee Overland V8, 2009 Liberty Rocky Mt V6
Previous: 2000 Grand Cherokee Laredo I6, 1979 CJ7 I6 Quadratrac
ColdCase is offline  
post #6 of 9 Old 10-09-2021, 02:34 PM Thread Starter
dtrkyman
Registered User
2013 WK 
 
Join Date: Feb 2012
Location: Santa Fe
Posts: 445
I think I hear the solenoid click? Engine turns freely, got it to fire once every thing is normal once running.

No codes, engine light off once it runs, gonna test battery and check grounds.

Was in mud prior to issue but then again I’m often in mud!


Sent from my iPhone using Tapatalk
dtrkyman is offline  
post #7 of 9 Old 10-15-2021, 07:01 PM Thread Starter
dtrkyman
Registered User
2013 WK 
 
Join Date: Feb 2012
Location: Santa Fe
Posts: 445
The new starter was bad, another new starter everything working.


Sent from my iPhone using Tapatalk
dtrkyman is offline  
post #8 of 9 Old 10-15-2021, 10:14 PM
ColdCase
My Reality Check Bounced
 
ColdCase's Avatar
2011 WK 
 
Join Date: Sep 2009
Location: New England
Posts: 18,314
I hate it when replacement parts are bad. Thanks for the update.

I just got lost in thought. It was unfamiliar territory;
Current: 2011 Grand Cherokee Overland V8, 2009 Liberty Rocky Mt V6
Previous: 2000 Grand Cherokee Laredo I6, 1979 CJ7 I6 Quadratrac
ColdCase is offline  
post #9 of 9 Old 10-21-2021, 10:15 AM Thread Starter
dtrkyman
Registered User
2013 WK 
 
Join Date: Feb 2012
Location: Santa Fe
Posts: 445
Yeah talk about the part not to get a bad one, what a cluster to replace that starter, glad it wasn't me working on it! We did some other checks prior to replacing again with no help.

Put in a new battery which didn't help that issue but being the original battery was still in the vehicle I just replaced anyway.
dtrkyman is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome