2017 Grand Cherokee difficulties accelerating, loud and backfires - JeepForum.com
 
LinkBack Thread Tools
post #1 of 8 Old 12-09-2019, 11:04 AM Thread Starter
abritton
Registered User
 
Join Date: Dec 2019
Posts: 3
Unhappy 2017 Grand Cherokee difficulties accelerating, loud and backfires

My 2017 Grand Cherokee is having difficulty accelerating (miles 39K). I can get up to about 2 RPMs but it really struggles and it is extremely loud. The grinding sounded like there was a hole in my muffler and I though the noise was coming from a supped up sports car. When I can finally get up to 20-30 MPH it backfires. It backfired numerous times as I gained speed especially if I drove over a bump. I turned my vehicle off three times but it still reacted the same. I was able to get up to 63 on the highway but it was a struggle. Verified everything was normalized and turned off my eco mode and auto shut. I drove straight to the dealer and they were unable to recreate it. They didn't look at it until the next day. I have the extended warranty but they aren't honoring the rental just waiving the diagnostic fee since they couldn't find the problem. About 2 weeks ago it did shut down at a light about 5 minutes into my drive. Other than that nothing else has happened to the car. Maintenance was last performed on 10/2 and no check engine light. Any ideas.

abritton is offline  
Sponsored Links
Advertisement
 
post #2 of 8 Old 12-11-2019, 05:49 PM
gcburke
Registered User
 
Join Date: Oct 2019
Posts: 34
Did they any codes ? What you describes had to generate fault codes of some kind.
gcburke is offline  
post #3 of 8 Old 12-11-2019, 08:46 PM
ColdCase
My Reality Check Bounced
 
ColdCase's Avatar
2011 WK 
 
Join Date: Sep 2009
Location: New England
Posts: 14,811
Yeah, did you get a check engine light? Things like an intermittent crank or cam position sensor, sticky phasers, engine harness can do this kind of thing.

Is this a v6 or v8?

I was born to party, but I am forced to work
Current: 2011 Grand Cherokee Overland V8, 2009 Liberty Rocky Mt V6
Previous: 2000 Grand Cherokee Laredo I6, 1979 CJ7 I6 Quadratrac
ColdCase is offline  
 
post #4 of 8 Old 12-12-2019, 11:21 AM Thread Starter
abritton
Registered User
 
Join Date: Dec 2019
Posts: 3
V6 and no check engine light. It did it again yesterday so I recorded the sound and took it is back to the dealer. The mechanic test drove with me but of course it didn't occur again. This time it didn't happen until 20 minutes into my drive and again only while accelerating but no backfiring. Happened for 15 minutes so the Jeep wasn't cold or running hot.
abritton is offline  
post #5 of 8 Old 12-12-2019, 12:13 PM
BigTizzie
Registered User
 
BigTizzie's Avatar
2011 WK 
 
Join Date: Jun 2016
Location: Moneyapolis, MN
Posts: 489
My guess is fuel pump. But not sure what code it would throw.

Can they access the history codes???

I'd check the air intake for obstructions.
BigTizzie is offline  
post #6 of 8 Old 12-13-2019, 10:56 AM
JeepCares
FCA Customer Care
 
JeepCares's Avatar
 
Join Date: Jan 2012
Location: MOPAR World Headquarters
Posts: 5,485
Quote:
Originally Posted by abritton View Post
V6 and no check engine light. It did it again yesterday so I recorded the sound and took it is back to the dealer. The mechanic test drove with me but of course it didn't occur again. This time it didn't happen until 20 minutes into my drive and again only while accelerating but no backfiring. Happened for 15 minutes so the Jeep wasn't cold or running hot.
Hi abritton,
We're sorry to hear about your experience. If you would like an additional layer of assistance while working with your dealer, please send us a PM.
Alex
JeepCares
JeepCares is online now  
post #7 of 8 Old 12-18-2019, 06:12 AM Thread Starter
abritton
Registered User
 
Join Date: Dec 2019
Posts: 3
The dealer repair shop called me two days ago stating they still could not recreate the problem. They told me I needed to come in and drive my car with their mechanic and if it didn't happen I would need to give back their loaner. Yesterday I actually had a funeral and couldn't participate in their demand. So today I'm taking leave and driving with their mechanic hoping to make it happen for them as the audio just isn't enough. I'm really torn about their customer service. I've recorded at least 10 minutes of the sound. I've been offered a Jeep Renegade and now a Chrysler as loaners. They act like driving a loaner car is preferred vs the car I purchased which is a Grand Cherokee. I've been told I can't even have my own dogs in the car nor can I leave the area. Feels like an inconvenience and now losing paid leave. Then if it doesn't occur I'll be driving around concerned I'm going to damage my car and the problem reoccurs what my safety could be. Plus the inconvenience of taking it back a 3rd or however many more times until they find the problem.

So glad I got an extended warranty and purchased what I thought was a reliable car needed to get to and from work. That's my latest update.
abritton is offline  
post #8 of 8 Old 12-18-2019, 04:09 PM
2008OverlandCRD
Registered User
2017 WK 
 
Join Date: Nov 2007
Location: Bellingham, WA
Posts: 415
The pitty party rants are off putting. Lol.

Just drive it till it dies. If you have the extended warranty then it’ll get fixed.

2017 Jeep Grand Cherokee Summit 4x4, 5.7 Hemi, platinum pkg, ivory 3-coat, skid plates.
2008OverlandCRD is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome