2012 Grand Cherokee Issues - JeepForum.com
 
LinkBack Thread Tools
post #1 of 3 Old 05-24-2019, 07:32 PM Thread Starter
ChuckCastiglion
Registered User
 
Join Date: Jun 2011
Location: greenville
Posts: 4
2012 Grand Cherokee Issues

Our 2012 GC has had starter push button issues since last year. We have to push the button 3 separate times before the starter will crank and then the car starts perfectly. If you pop the start button out and use the key/fob in the hole, it starts perfectly. If you use the remote start it works perfectly. I posted this same issue last year. There are also some other issues that I believe are related. The cruise control dash indicator will not come on and therefore doesn't work. And the radio will remain "ON" for a while after the car is turned "OFF' and the door is opened. The brake light switch seems to work fine. Anyone have any thoughts? Thanks in advance! Happy Memorial weekend!:

ChuckCastiglion is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 05-25-2019, 08:51 AM
woodsy18
Registered User
 
Join Date: May 2018
Posts: 106
Have you replaced the fob batteries yet? My 12 seems to have starting issues around the same time as the battery goes out in the fob

Sent from my SM-G950U using Tapatalk
woodsy18 is offline  
post #3 of 3 Old 05-25-2019, 11:05 AM
ColdCase
My Reality Check Bounced
 
ColdCase's Avatar
2011 WK 
 
Join Date: Sep 2009
Location: New England
Posts: 13,677
Sure sounds like a FOB, PEM, or PEM antenna issue, there are four of them running under the carpets. I forget if you need to have a foot on the brake to start with the button popped out, but if not, the brake switch could be intermittent. Its like a three contact switch, the brake lights being on a separate contact. There was a tread here awhile ago where a member replaced the brake switch and all was well. Did the dealer replace the brake switch or check the PEM antennas? Was the PEM ever replaced? Do both FOBs act the same?

Current: 2011 Grand Cherokee Overland V8, 2009 Liberty Rocky Mt V6
Previous: 2000 Grand Cherokee Laredo I6, 1979 CJ7 I6 Quadratrac
ColdCase is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
2012 JK introduction and transfer case issues? Zah722 JK Wrangler 0 02-19-2019 10:12 PM
Electrical/Engine Issues with 2015 Wrangler jb1378 JK Wrangler Technical Forum 4 09-23-2018 01:06 AM
2017 Renegade Lemon Law Process due to many issues. 4x4inmyjeep Jeep BU Renegade & MP Compass Forum 4 09-19-2018 06:51 PM
2012 Laredo radio issues Stochmal52 WK2 Grand Cherokee Forum 2 08-10-2018 03:48 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome