Weird fade... - JeepForum.com
 1Likes
  • 1 Post By pshivers
 
LinkBack Thread Tools
post #1 of 3 Old 09-01-2019, 02:19 PM Thread Starter
Chereveco
Registered User
2008 KK Liberty 
 
Join Date: May 2016
Location: San Jose
Posts: 130
Garage
Weird fade...

Since some months ago; I have started feeling that if I stop, turn the wheels and accelerate to do a U turn, If I hit the break pedal, it "fades", sometimes to the scaring point, when you are not expecting it to happen.

Then it brakes normally, and so on.

Fluid is in proper level, no leaks, brake pads are like at 40% to replacement. Two years ago replaced all the calipers...

What can this weirdo Gremlin be?

Regards

Sent from my SNE-LX3 using Tapatalk


Neil Cordoba de Jongh
Costa Rica
Chereveco is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 09-02-2019, 10:54 PM
pshivers
Registered User
2008 KK Liberty 
 
Join Date: Sep 2012
Location: Westerville
Posts: 391
If there is no leak, it's either air left in the line after you replaced all the calipers, a leaking master cylinder seal and the fluid is returning to the reservoir or the rubber line is twisted when you replaced the caliper.

Sent from my Samsung S8+ using Tapatalk
Chereveco likes this.
pshivers is offline  
post #3 of 3 Old 09-03-2019, 12:52 PM Thread Starter
Chereveco
Registered User
2008 KK Liberty 
 
Join Date: May 2016
Location: San Jose
Posts: 130
Garage
Thanks I'm going to checkout everything again,

Sent from my SNE-LX3 using Tapatalk

Neil Cordoba de Jongh
Costa Rica
Chereveco is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome