Sudden radio silence? - JeepForum.com
 
LinkBack Thread Tools
post #1 of 2 Old 08-11-2020, 11:56 PM Thread Starter
Swisscheese
Registered User
 
Swisscheese's Avatar
 
Join Date: Nov 2018
Posts: 4
Sudden radio silence?

Hi folks
I hope you are all fine these days!
I was driving on the highway yesterday and when i wanted to listen to the radio but there was silence. I have the radio navigation system from the original 2009KK.
The volume knob had no function, i could‘t change the audio preferences anymore (speaker balance, eq), It felt like I touched a hidden mute button. No matter if radio,cd or hdd, no sound at all, also the uconnect didn‘t work.
On my way to work last morning everything was fine.
Any ideas what could have caused this?

Thanks for any suggestions and keep on jeeping

Claudio

Swisscheese is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old 08-12-2020, 07:53 PM
kensil
Registered User
2012 WK 
 
Join Date: Jul 2012
Location: Silcon Valley
Posts: 38
I have a 2012 Liberty with the OEM nav radio (MEDIA CENTER 430/430N (RBZ/RHB)), but have not had a similar problem. Sometimes power cycling the electronics by disconnecting the battery for 15 min. helps to reset things back to normal.
kensil is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome