Retrieving OBD2 Codes - JeepForum.com
 1Likes
  • 1 Post By lfhoward
 
LinkBack Thread Tools
post #1 of 7 Old 08-10-2020, 09:14 AM Thread Starter
DragoneFire
Registered User
2011 KK Liberty 
 
Join Date: Aug 2019
Location: Las Vegas
Posts: 18
Retrieving OBD2 Codes

2011 Jeep Liberty
Driving to work, my CEL came on 3 times, my OBD2 scanner at home, how can I retrieve the code before heading back home. Read a couple of things but they weren't really specific.
Turn the key 3 times from off to right before run or something with my odometer I didn't understand, let me know

DragoneFire is offline  
Sponsored Links
Advertisement
 
post #2 of 7 Old 08-10-2020, 11:24 AM
lfhoward
Registered User
 
lfhoward's Avatar
2008 KK Liberty 
 
Join Date: Nov 2012
Location: Philadelphia
Posts: 1,366
Seems this old trick doesn’t work in the newer models. I’m not sure at which point Jeep stopped supporting it.

I’d try stopping at an auto parts store. Most of them will read codes for free.
jtec likes this.

2008 Liberty Sport 4x4 Automatic
4" JBA Lift & 245/75R16 BFG KO2's
ATH Recovery System & Roof Rack
lfhoward is offline  
post #3 of 7 Old 08-10-2020, 04:04 PM Thread Starter
DragoneFire
Registered User
2011 KK Liberty 
 
Join Date: Aug 2019
Location: Las Vegas
Posts: 18
I should've mentioned I'm 2.5 hours from the nearest garage. Was just trying to find out what it may be before driving back to town and ruining something
DragoneFire is offline  
 
post #4 of 7 Old 08-10-2020, 06:36 PM
lfhoward
Registered User
 
lfhoward's Avatar
2008 KK Liberty 
 
Join Date: Nov 2012
Location: Philadelphia
Posts: 1,366
That’s too bad. If the check engine light was flashing, definitely don’t drive it. When it came on 3 times did the Jeep feel any different? Any misfires/bucking or loss of power, or anything you noticed that pointed to an immediate problem?

2008 Liberty Sport 4x4 Automatic
4" JBA Lift & 245/75R16 BFG KO2's
ATH Recovery System & Roof Rack
lfhoward is offline  
post #5 of 7 Old 08-11-2020, 06:19 PM Thread Starter
DragoneFire
Registered User
2011 KK Liberty 
 
Join Date: Aug 2019
Location: Las Vegas
Posts: 18
No, absolutely no change in response, upshift, downshift, no dimming of lights when i stopped. It didn't blink, it came on, then went out like i dont know 5-10 seconds later 3 times
DragoneFire is offline  
post #6 of 7 Old 08-11-2020, 07:22 PM
lfhoward
Registered User
 
lfhoward's Avatar
2008 KK Liberty 
 
Join Date: Nov 2012
Location: Philadelphia
Posts: 1,366
It doesn’t sound that bad, whatever it is. Maybe you have a loose gas cap? Anyhow, you could try driving it home and keep the number for Triple-A on the seat next to you.

2008 Liberty Sport 4x4 Automatic
4" JBA Lift & 245/75R16 BFG KO2's
ATH Recovery System & Roof Rack
lfhoward is offline  
post #7 of 7 Old 08-24-2020, 01:23 PM Thread Starter
DragoneFire
Registered User
2011 KK Liberty 
 
Join Date: Aug 2019
Location: Las Vegas
Posts: 18
Update: Got it home, hooked up my Blue Driver, P0300, P0301 codes. Was due for a tuneup anyway so got new plugs and new coils, installed, cleared codes. Took for drive same codes came back. Anyone run into same thing. Gonna start a list of whats been done so I can try different things before thinking it may be internal engine thing.

1. New plugs from dealer, gapped to .043
2. New Delphi coils
DragoneFire is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome