Power port fuses - JeepForum.com
 
LinkBack Thread Tools
post #1 of 3 Old 10-29-2019, 12:44 PM Thread Starter
napa1
Registered User
 
Join Date: Jul 2019
Posts: 24
Power port fuses

My 2005 Liberty undoubtedly has a blown fuse?? Not sure which one it is. Know where the fuses are but see no blown ones? Front power port and rear has NO VOLTAGE. Any help on this??
Bill NAPA Man

napa1 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 12-06-2019, 12:05 AM
Steve.A
Registered User
 
Steve.A's Avatar
2003 WJ 
 
Join Date: Jul 2019
Location: Louisville
Posts: 32
The manual shows that cavity #3 is for your front and #16 for the rear. These are both Yellow 20 amp fuses. This is the fuse panel on the left side of the instrument panel in the cabin, not under the hood.
Steve.A is offline  
post #3 of 3 Old 12-07-2019, 10:13 AM Thread Starter
napa1
Registered User
 
Join Date: Jul 2019
Posts: 24
Yes , I did pull both fuses and they looked OK but did not check with my VOM. Kind of weird as they both quite at the same time?? Weather too cold to mess now so will wait for a warmer day and sunshine.
napa1 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome