Ghost in the KK!!! - JeepForum.com
 1Likes
  • 1 Post By Jumpstix
 
LinkBack Thread Tools
post #1 of 2 Old 09-05-2019, 06:13 PM Thread Starter
WESTS_JEEPS
Registered User
 
WESTS_JEEPS's Avatar
1979 CJ7 
 
Join Date: Mar 2014
Location: EUREKA
Posts: 9
Garage
Ghost in the KK!!!

My daughter owns a ‘08 Liberty 4x4. The last month it has had some weird electrical issues.
Since she bought it the turn signals wouldn’t turn off after returning to center. But no other issues, for about six months.
First issue was when she would lock/unlock doors the wipers would come on, horn honk, and lights flash unusually, door locks would lock/unlock sometimes. This happened a number of times.
Then while she was driving, she rounded a curve and the same issues happened.
Last week she was driving and the Jeep either put itself into 4 LOW or applied the fully applied brakes while driving 50 mph!!! She almost crashed!
She parked it while I research issue.
Searched this and other forums and got a consensus of a bad TIPM. Purchased a Reman unit from Dorman and installed today.
Same issues still exists.
Test drove. Drove fine. But the turn signal issue still exists and the doors will lock themselves. The lock/unlock button on the door doesn’t work sometimes. The keys fob seems to work when it wants too, and I believe the buttons on the fob switched lock/unlock functions.
Could it be the clock spring or something to do with the turn signals?
Or the wireless module in the steering column?
If I replace the wireless module, does it have to be reprogrammed?
Thank you in advance for your help.

WESTS_JEEPS is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old 09-11-2019, 09:38 PM
Jumpstix
Newbie
2008 KK Liberty 
 
Join Date: Sep 2019
Posts: 2
Wireless Control Module

I had the dealer replace and load Jeep's proprietary software on our '08 this past Monday (9-09-'19). We had similar issues and found a technical service bulletin from Jeep telling dealers this module needed to be replaced for Liberties that were manufactured prior to 5-'08. Our Liberty was built 4-'08. So far, after 3 days of driving, our issues have gone away. Dealer cost for the WCM, programming, and labor was $305, in central Iowa. I had to insist that the Service Manager replace this item, even after showing him a video of the Liberty going loco and presenting him with a printed copy of the TSB. Date of manufacture sticker is located on the driver's side door. Good luck.
WESTS_JEEPS likes this.
Jumpstix is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome