Brake lights not working on my 2011 Liberty - JeepForum.com
 
LinkBack Thread Tools
post #1 of 2 Old 01-27-2020, 05:47 PM Thread Starter
2511
Registered User
2011 KK Liberty 
 
Join Date: Mar 2018
Posts: 21
Brake lights not working on my 2011 Liberty

Today I was told by a guy next to me, at a stop light, that my brake lights were not working except for the center hatch brake light. It works. I have no idea how long they have been out.
When I got home, I checked the backup lights, turn signal lights and running lights and they all work. Just the brake lights on both sides are out.

I pulled one side off to take a look but could not tell how to unplug the harness from the light assembly much less how to get to the bulbs. It looks like a sealed unit.
Has anyone had this problem and if so how did you fix it?
Thanks in Advance, Alan
Update: I found a Youtube on how to get to the light bulbs. Replaced light bulbs and the brake lights work.


Last edited by 2511; 01-27-2020 at 07:33 PM.
2511 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old 01-27-2020, 10:07 PM
hersheleller40
Registered User
1937 CJ2A 
 
Join Date: Jan 2018
Location: TN
Posts: 67
There is a long strip in the back of the tail light that holds the bulbs. It is hell on by 2 or 3 torch screws. Remove the screws and it just pulls off.


Sent from my iPhone using Tapatalk
hersheleller40 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome