4WD won't engage - JeepForum.com
 
LinkBack Thread Tools
post #1 of 3 Old 07-21-2021, 04:25 PM Thread Starter
vdavis1959
Registered User
 
Join Date: Apr 2016
Posts: 3
4WD won't engage

I have a 2011 Jeep Liberty Sport 3.7 L engine (gas) that the 4WD wont’ engage. I don’t hear the clunk underneath when trying to go into 4WD. This only happens when the 4WD, 4low and Stability control symbol lights up on dash board. In addition it shows “ESC OFF” in the odometer mileage LED.


Last edited by vdavis1959; 07-21-2021 at 04:49 PM.
vdavis1959 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 07-22-2021, 07:22 AM
ColdCase
My Reality Check Bounced
 
ColdCase's Avatar
2011 WK 
 
Join Date: Sep 2009
Location: New England
Posts: 17,646
There may be TC controller diagnostic codes, when that happens you see those other indications. Your everyday OBD reader isn't going to see those codes.

Check the fluid level. Otherwise it could be the shift motor, Final Drive Control Module, or jammed up transfer case.

I just got lost in thought. It was unfamiliar territory;
Current: 2011 Grand Cherokee Overland V8, 2009 Liberty Rocky Mt V6
Previous: 2000 Grand Cherokee Laredo I6, 1979 CJ7 I6 Quadratrac
ColdCase is online now  
post #3 of 3 Old 07-22-2021, 02:39 PM Thread Starter
vdavis1959
Registered User
 
Join Date: Apr 2016
Posts: 3
Thanx for you reply, I'll check those out.
vdavis1959 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome