2012 KK sport dash backlight issues - JeepForum.com
 
LinkBack Thread Tools
post #1 of 13 Old 10-01-2019, 09:07 PM Thread Starter
Libertyjeep2012
Registered User
 
Join Date: Oct 2019
Posts: 17
2012 KK sport dash backlight issues

I think I am ginxed. Wife has a 2007 Lib and we love it. Just bought a 2012 with 65k for 10000 and have had issues.

Here is the list. Test drive, sales said it was the ready yet. Had a check engine light on and FM on radio didn't work. They gave a 6000 Mike engine dealer warranty with it or 6 month months.

They replaced a coil pack and the radio. After a week started to have an issue with loud tapping like exhaust manifold. They repaired it although it didn't happen for them. I had a video. Replaced rockers said one was soft and lifters... I pick it up and in the parking lot check engine light. They give me a loaner. They say issue was water in the plugs when cleaning and they dried it off.

Week later, fuel backlight is out for days then comes in. Half speedometer light randomly goes off or dims when I adjust dimmer for backlight. Rest of dash is fine. Bumping dash hard does nothing. Adjusting dimmer to off then on sometimes brings it back. Sometimes for days it's fine. I also found it has a remote starter in it which the dealer didn't know and I discovered from it's antenna. 3 lock presses will start it.

Today had a p0303 code go on and also noticed a key fob Immobizizer code and cruise control. Not sure if these are related or leftover from when they worked on it although no check engine light was on. I cleared the code none of them have come back. Dash light however is the same. Not sure if warranty will cover a cluster or dimmer / the signal switch.

Any thoughts, this jeep is driving me nuts. The battery in it is some off brand. Do you think it could cause weird issues like this, remote start or turn signal / headlight switch? Headlighys and turnsignals work fine. I think other taillights are fine but need someone to check behind me to verify. Help

Libertyjeep2012 is offline  
Sponsored Links
Advertisement
 
post #2 of 13 Old 10-01-2019, 09:08 PM Thread Starter
Libertyjeep2012
Registered User
 
Join Date: Oct 2019
Posts: 17
Correction sales said the jeep was not ready yet as they had not cleaned it.
Libertyjeep2012 is offline  
post #3 of 13 Old 10-03-2019, 04:42 PM Thread Starter
Libertyjeep2012
Registered User
 
Join Date: Oct 2019
Posts: 17
Ok to add on to this. Raining today all dash lights working until after it stopped. Then fuel backlight off and after adjusting backlight dimmer temp gauge backlight off until I adjusted dimmer a few times. I bumped all marker lights and taillights nothing. Opened the TPIM and pushed on all fuses. Also bumped the top. Checked and fuel back light was on. Adjusted dimmer went off again. Repeated, no difference. Is it possible the TPIM has a bad ground or a fuse is acting up? Where to start fuse wise on a 2012? May pull the battery cables this weekend clean the terminals and TPIM ground. Any thoughts?
Libertyjeep2012 is offline  
 
post #4 of 13 Old 10-03-2019, 04:43 PM Thread Starter
Libertyjeep2012
Registered User
 
Join Date: Oct 2019
Posts: 17
Btw tapping dimmer, switch for turn signal and dash makes no difference.
Libertyjeep2012 is offline  
post #5 of 13 Old 10-06-2019, 08:51 PM Thread Starter
Libertyjeep2012
Registered User
 
Join Date: Oct 2019
Posts: 17
Update if anyone is following this. Started it up today while it was raining. All dash lights worked. Dimmed it and fuel backilght went out again. Also had a missfire on cylinder 5. Pulled it into the garage. Noticed as soon as i plugged my scanner in dash lights restored and seemed ok dimming. After scanner was unplugged seemed to have the issues again. (may have just been a coincidence. Disconnected battery for 2 hours. reconnected. Dash lights all worked again, codes cleared. Drove it for a bit testing the dimmer for the dash. Half speedometer went dim. Stopped at Autozone. tested battery. Battery is fine. Grabbed some plugs. Replaced all sparkplugs. Man the gaps were horrible on the old ones. Gapped new ones at 43 which matches my book. Took it for a drive. Dash light issue still but plug replacement seems to have given it some more power.

I also found that it has a Compustart DC2 remote starter which can be activated via my key fob. Wiggling it made no difference.
Libertyjeep2012 is offline  
post #6 of 13 Old 10-06-2019, 09:11 PM
tomknight
Registered User
 
tomknight's Avatar
2011 KK Liberty 
 
Join Date: Jul 2016
Posts: 17
Changed my daughter's plugs today (she and I both have KK's). They were so worn down, the gaps was about .6 - .65.

What a difference that makes. Sorry to hear about your dash issues - hope you find something on it. I was able to download a service manual - not sure if that would help you or not. If you think it would, DM me, and i'll post it someplace where you can download it.

2011 Liberty Limited
2006 Liberty Limited
tomknight is offline  
post #7 of 13 Old 10-07-2019, 09:11 PM Thread Starter
Libertyjeep2012
Registered User
 
Join Date: Oct 2019
Posts: 17
Ok today raining. Jeep started making a clacking sound (I had to take it to a dealer and they replaced the rockers and lifters which seemed to work for a week) them it threw a code. P0300 and P0305. We t to AutoZone and got a could pack and a other if just in case.fired it up. Same noise. Checked all coil connections on all packs. Started up and sounded the same but then went back to normal. ( Original issue would do that for like 1 mile). Drove it around and it sounded normal. No check engine light but Checked scanner. Scanner shows a P0300 but not Confirmed or pending and showed a P0303. Is it possible I have 2 coil packs that went at the same time? ( All plugs have been changed and gapped and they are ngk copper). When I test.drove the jeep it had a P0301 code and they said they fixed it with a coil pack which i confirmed. Any thoughts? If it shows P0303 I will get the coil pack but all this is adding up for a jeep I just send my first payment out on plus loss of family time fixing it. Btw file dash backlight still goes out.
Libertyjeep2012 is offline  
post #8 of 13 Old 10-07-2019, 09:28 PM
hersheleller40
Registered User
1937 CJ2A 
 
Join Date: Jan 2018
Location: TN
Posts: 53
I had a truck that didnít get used much. The elements caused corrosion on the electrical plugs. You might check for corrosion. As far as the coil packs go; I replaced my plugs and all coil packs.


Sent from my iPhone using Tapatalk
hersheleller40 is offline  
post #9 of 13 Old 10-08-2019, 09:21 AM
JeepCares
FCA Customer Care
 
JeepCares's Avatar
 
Join Date: Jan 2012
Location: MOPAR World Headquarters
Posts: 5,364
Quote:
Originally Posted by Libertyjeep2012 View Post
Ok today raining. Jeep started making a clacking sound (I had to take it to a dealer and they replaced the rockers and lifters which seemed to work for a week) them it threw a code. P0300 and P0305. We t to AutoZone and got a could pack and a other if just in case.fired it up. Same noise. Checked all coil connections on all packs. Started up and sounded the same but then went back to normal. ( Original issue would do that for like 1 mile). Drove it around and it sounded normal. No check engine light but Checked scanner. Scanner shows a P0300 but not Confirmed or pending and showed a P0303. Is it possible I have 2 coil packs that went at the same time? ( All plugs have been changed and gapped and they are ngk copper). When I test.drove the jeep it had a P0301 code and they said they fixed it with a coil pack which i confirmed. Any thoughts? If it shows P0303 I will get the coil pack but all this is adding up for a jeep I just send my first payment out on plus loss of family time fixing it. Btw file dash backlight still goes out.
Hi Libertyjeep2012,
We're sorry to hear about your experience with your Jeep. If you decide to work with your dealer towards a resolution, please send our team a private message. We'd be happy to connect you with a Case Specialist.
Alex
Jeep Cares
JeepCares is online now  
post #10 of 13 Old 10-08-2019, 10:50 AM Thread Starter
Libertyjeep2012
Registered User
 
Join Date: Oct 2019
Posts: 17
Replaced coil pack on cylinder 5 last night. Still made the clacking but seemed like less. This morning clacking again for about a minute. At lunch same then check engine light. Read a code p0300 and P0303, the only coil pack I haven't replaced. Going to see if if I get any other codes and probably replace the last coil. After that I may talk to jeep care and the dealer.
Libertyjeep2012 is offline  
post #11 of 13 Old 10-08-2019, 08:10 PM Thread Starter
Libertyjeep2012
Registered User
 
Join Date: Oct 2019
Posts: 17
Tonight after replacing coil pack 3, still clicked but code P0303 didn't come back after clearing. Went to store. Noticed temp a little high. Leveled out when driving. Idled in front of my house and temp went above 3/4 and temp light came on.

Calling dealer in the morning. Hope I can make it 30 miles.
Libertyjeep2012 is offline  
post #12 of 13 Old 10-09-2019, 08:38 PM Thread Starter
Libertyjeep2012
Registered User
 
Join Date: Oct 2019
Posts: 17
Just an update, there was no corrosion. Plugs to coil packs looked brand new. Jeep went back to the dealer to figure out. They gave me a loaner caravan. Antifreeze was down about 20 ounces but still in the overflow. I topped it off. Jeep did not clack but idled a little rough. Drove it to the dealer, no overheat. Thinking either computer since I have the dash light issue but it's on them. I am in co tact also with Jeep Care. Hopefully the dealer finds and fix the issue or refund me. I provided the dealer with an email of every issue, video of clacking, pictures of codes, antifreeze when lower and steps I tried to mediate it with. I hope it rains and it acts up cuz if they tell me it runs fine I think I will explode lol. Just made my 1st payment and the 150 miles I put on it, half was going to the dealer.
Libertyjeep2012 is offline  
post #13 of 13 Old 10-15-2019, 02:30 PM Thread Starter
Libertyjeep2012
Registered User
 
Join Date: Oct 2019
Posts: 17
Well dealer is getting me a Cylinder 3 head and replacing it. I will update later. Looks like I am with the loaner for another week. Covered under warranty.
Libertyjeep2012 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome