2010 KK crank issue - JeepForum.com
 
LinkBack Thread Tools
post #1 of 12 Old 09-09-2021, 03:41 PM Thread Starter
97_JGC
Registered User
1997 ZJ 
 
Join Date: Dec 2012
Location: Crawford
Posts: 52
2010 KK crank issue

Has anyone experienced this " no crank " issue. Used to do it very intermittently, once every few months, becoming increasingly common, 5 - 10 times in a row every couple of weeks. You can hear the starter engage and then "die out". Both starter and battery are new, battery connections clean and tight. No codes.




97_JGC is offline  
Sponsored Links
Advertisement
 
post #2 of 12 Old 09-23-2021, 06:07 AM
mikecs4life
Registered User
 
mikecs4life's Avatar
2004 WJ 
 
Join Date: Sep 2018
Posts: 2
Im having the same issue. It engages for a half a second then stops. After 15-20 tries it will fire. I now have it jumped to a toggle switch from the relay and it cranks and starts every time, so its not the starter, ignition switch, or fuses. Any help would be greatly appreciated.
mikecs4life is offline  
post #3 of 12 Old 09-23-2021, 09:21 AM
Ex-Calif
Registered User
2012 KK Liberty 
 
Join Date: Apr 2015
Location: Cincinnati
Posts: 76
For both of you it sounds like it could be a bad start relay. Here is a cool video I found that has a quick "relay swap" that you can test with.


2012 Liberty Sport
WWII - Horses vs. Jeeps - 'nuff said...
Ex-Calif is offline  
 
post #4 of 12 Old 09-26-2021, 11:23 AM Thread Starter
97_JGC
Registered User
1997 ZJ 
 
Join Date: Dec 2012
Location: Crawford
Posts: 52
[QUOTE=Ex-Calif;41361015]For both of you it sounds like it could be a bad start relay. Here is a cool video I found that has a quick "relay swap" that you can test with.

Thank you for the suggestion, ordered a new relay this morning. Does not seem to be a very common issue, only came across one thread in a Nitro forum.
97_JGC is offline  
post #5 of 12 Old 09-27-2021, 07:04 AM
Ex-Calif
Registered User
2012 KK Liberty 
 
Join Date: Apr 2015
Location: Cincinnati
Posts: 76
Did you do the relay swap first? Was that the issue?

2012 Liberty Sport
WWII - Horses vs. Jeeps - 'nuff said...
Ex-Calif is offline  
post #6 of 12 Old 09-27-2021, 01:51 PM Thread Starter
97_JGC
Registered User
1997 ZJ 
 
Join Date: Dec 2012
Location: Crawford
Posts: 52
Quote:
Originally Posted by Ex-Calif View Post
Did you do the relay swap first? Was that the issue?
No my issue is still fairly intermittent, for the $20 I will just replace with a new one and see over time if that was the issue.
97_JGC is offline  
post #7 of 12 Old 09-30-2021, 12:32 PM
raider56
Registered User
 
raider56's Avatar
 
Join Date: May 2016
Location: Bayside
Posts: 2
I have the same intermittent issue, I even have Major Guard and all they did was change the started which didn't work on the problem. There was a Star case on it that referenced bad grounds, but it was never found. Never heard of the relay fix.

Does anyone know what relay to order to swap it out?

Thanks!
raider56 is offline  
post #8 of 12 Old 10-01-2021, 04:13 PM Thread Starter
97_JGC
Registered User
1997 ZJ 
 
Join Date: Dec 2012
Location: Crawford
Posts: 52
Quote:
Originally Posted by raider56 View Post
I have the same intermittent issue, I even have Major Guard and all they did was change the started which didn't work on the problem. There was a Star case on it that referenced bad grounds, but it was never found. Never heard of the relay fix.

Does anyone know what relay to order to swap it out?

Thanks!
I found the location of my starter relay on this page.

https://fuse-box.info/jeep/jeep-libe...ses-and-relays

The part number itself I got off the factory relay which is located in the fuse box right behind the battery.

I just installed the new relay today so time will tell if that is the issue. I found someone with a Dodge Nitro [which is essentially what are Libby's are] and a new relay did NOT solve his issue. Whether he changed the correct one or not who knows. He had also changed the starter, battery and ignition switch with no success. Not much left after all that I suppose. Watch Wes Work described our ignition system as overly complicated. He goes into the schematic in this video.

Will report back to this thread either way.

97_JGC is offline  
post #9 of 12 Old 10-03-2021, 05:13 AM
Ex-Calif
Registered User
2012 KK Liberty 
 
Join Date: Apr 2015
Location: Cincinnati
Posts: 76
I'd love to hear the results. It could be the ignition switch on the column itself as well, I suppose.

2012 Liberty Sport
WWII - Horses vs. Jeeps - 'nuff said...
Ex-Calif is offline  
post #10 of 12 Old 10-03-2021, 09:10 AM Thread Starter
97_JGC
Registered User
1997 ZJ 
 
Join Date: Dec 2012
Location: Crawford
Posts: 52
Quote:
Originally Posted by Ex-Calif View Post
I'd love to hear the results. It could be the ignition switch on the column itself as well, I suppose.
The fella that had the Nitro had a garage swap out his ignition switch but he still had the issue. If the problem persists with the new relay I will swap the ignition switch out anyway.
97_JGC is offline  
post #11 of 12 Old 10-23-2021, 03:32 PM Thread Starter
97_JGC
Registered User
1997 ZJ 
 
Join Date: Dec 2012
Location: Crawford
Posts: 52
Well, unfortunately the new relay did not solve the issue. Maybe got 15 or so normal starts until it occurred again.
97_JGC is offline  
post #12 of 12 Old Yesterday, 06:47 PM
ColdCase
My Reality Check Bounced
 
ColdCase's Avatar
2011 WK 
 
Join Date: Sep 2009
Location: New England
Posts: 18,096
Someone had something similar on another forum here. He initially replaced the starter with no joy but after a bunch of dead end troubleshooting, replaced with another starter and that worked for him. But I would double check the condition of all the grounds and battery voltage while trying to start before trying another starter.

I just got lost in thought. It was unfamiliar territory;
Current: 2011 Grand Cherokee Overland V8, 2009 Liberty Rocky Mt V6
Previous: 2000 Grand Cherokee Laredo I6, 1979 CJ7 I6 Quadratrac
ColdCase is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome