Speedometer dies all the time - JeepForum.com
 
LinkBack Thread Tools
post #1 of 5 Old 09-19-2019, 01:42 AM Thread Starter
Ninjasword71
Registered User
 
Join Date: Jun 2018
Posts: 7
Speedometer dies all the time

A year ago the shop fixed this problem with some wires and tightened some flange bolts to lessen the loud clunk when shifting from park. Now it's doing it again. You can feel a slight surge when the speedometer wakes up. Anyone have a solution that works? This jeep has been so disappointing in so many ways. To top it off, these things are all just 2 wheel drive. The two tires with no traction spin only.

Ninjasword71 is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old 09-19-2019, 08:11 AM
jtec
Registered User
 
jtec's Avatar
2014 JK Wrangler 
 
Join Date: Oct 2017
Posts: 6,546
What YEAR and engine would really help?

Did you have a SCAN done to see if there is a code that could assist in troubleshooting?


Sorry I digress - been reading Asian history -
Ninjasword71 - is name derived from the NINJA warriors?

When I see the price of OEM I think aftermarket.
When I see the quality of aftermarket I think OEM.
jtec is offline  
post #3 of 5 Old 09-19-2019, 12:08 PM Thread Starter
Ninjasword71
Registered User
 
Join Date: Jun 2018
Posts: 7
2003 and 3.7L. I am trained in ninjitsu, yes.
Ninjasword71 is offline  
 
post #4 of 5 Old 09-19-2019, 04:10 PM
jtec
Registered User
 
jtec's Avatar
2014 JK Wrangler 
 
Join Date: Oct 2017
Posts: 6,546
did you try a scan? I would suspect no input would set several codes.

Just reading the lore of Ninja - an legendary old world warrior, unparalleled in ability during the feudal times in Asia,Their legend continued into the 20th century, where the end came quickly when they were confronted and bested by a handful of UNITED STATES MARINES. Gotta love globalization.

When I see the price of OEM I think aftermarket.
When I see the quality of aftermarket I think OEM.
jtec is offline  
post #5 of 5 Old 09-23-2019, 12:09 PM Thread Starter
Ninjasword71
Registered User
 
Join Date: Jun 2018
Posts: 7
Haven't done a recent scan. An older scan said an abs pump fault. The speedometer went wild the other day, going from 0 to the other end of speedometer. Last year the pigtail by the rear diff was replaced along with tightening some flange bolts.
Ninjasword71 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome