More codes and thoughts on my dead transmission - JeepForum.com
 
LinkBack Thread Tools
post #1 of 7 Old 05-06-2017, 12:04 PM Thread Starter
olliehopnoodle
Registered User
1982 FSJ Cherokee 
 
Join Date: Sep 2012
Location: mesa
Posts: 1,255
More codes and thoughts on my dead transmission

Got these codes: p0841, p0731, p0876 (details below) Car wouldn't move under it's own power. After sitting for the night I was able to get it to move about 100 feet but then it stopped moving again.

One thing they all recommend is to check the transmission fluid level, which I did when it was cold. Today I let the jeep warm up a bit and pulled the dip stick. The fluid had small bubbles in it. Also, even cold the fluid level was actually high. I noticed on the dip stick the 'full cold' is almost at the very end and the 'full hot' is higher on the dip stick.

I think coolant from the radiator has been getting into the transmission cooling circuit. I have been having an issue with the coolant level needing to be topped off every couple of weeks and I haven't been able to find the leak. I have added about a gallon of water since February.

Thoughts? Next steps?

Can someone go check their fluid level when 'cold' and tell me where it is on the dipstick please?



Here are the codes:

p0876 "Low transmission fluid level, Faulty Transmission Fluid Pressure Switch, Transmission Fluid Pressure Switch harness is open or shorted, Transmission Fluid Pressure Switch circuit poor electrical connection, Faulty Powertrain Control Module


p0841 "low transmission fluid leve,l Dirty transmission fluid, Faulty Transmission Solenoid/Pressure Switch, Transmission Solenoid/Pressure Switch harness is open or shorted, Transmission Solenoid/Pressure Switch circuit poor electrical connection, Internal transmission damage, Faulty Engine Control Module (ECM), Faulty Transmission Control Module (TCM)


p0731 "low transmission fluid level, Dirty transmission fluid, Shift solenoids, Transmission mechanical problems, Transmission hydraulic control circuit


82 Cherokee WT - SOA/SF/agr box/Borgeson ujoint steering shaft/401/performer/holley TA/HEI/BeCool/727/np208/d44(aussie)/amc20(ARB)/BFG 35X12.5/Corbeau Moab Seats/RCI 6point Harness,Hella Aux lights/tuffy console/killer32 slider bars/custom bumpers and roll bar/Alpine head unit/amps/speakers 2002 Liberty Limited Early edition - Basically stock
olliehopnoodle is offline  
Sponsored Links
Advertisement
 
post #2 of 7 Old 05-06-2017, 12:24 PM
02blue
Registered User
2005 KJ Liberty 
 
Join Date: Aug 2011
Location: Frederick MD
Posts: 1,547
You owe me a beer

Just ran out and checked my 02 with the 45rfe. Cold and not running was actually past the hot mark. Cold and running (in park) was right at the cold full mark. Has to be running so that the fluid is circulating. Otherwise it's all in the pan.

I'd doubt it would be leaking coolant into the tranny but possible. I'd drop that pan ASAP and see what the fluid looks like and if you get any separation of the oil water variety. You could just plumb in an auxillary cooler and bypass the in rad one if this is the problem. Don't think there is much pressure going to the rad cooler. just circulates it.

"Hey, ya never know til you try." Kurt Russell-Big Trouble in Little China
02blue is offline  
post #3 of 7 Old 05-06-2017, 01:22 PM Thread Starter
olliehopnoodle
Registered User
1982 FSJ Cherokee 
 
Join Date: Sep 2012
Location: mesa
Posts: 1,255
Hey thanks 02Blue! Mine, cold and running, was still above the hot mark. I forget if there is a drain plug on the pan or not. Yeah, my coolant idea seems a bit off. I wonder if the coolant gets pushed in when the car is off and there is still pressure in the cooling system?

82 Cherokee WT - SOA/SF/agr box/Borgeson ujoint steering shaft/401/performer/holley TA/HEI/BeCool/727/np208/d44(aussie)/amc20(ARB)/BFG 35X12.5/Corbeau Moab Seats/RCI 6point Harness,Hella Aux lights/tuffy console/killer32 slider bars/custom bumpers and roll bar/Alpine head unit/amps/speakers 2002 Liberty Limited Early edition - Basically stock
olliehopnoodle is offline  
 
post #4 of 7 Old 05-06-2017, 03:19 PM
02blue
Registered User
2005 KJ Liberty 
 
Join Date: Aug 2011
Location: Frederick MD
Posts: 1,547
Maybe a strange idea but what if you just temporarily bypassed the rad tranny cooler with a tube and got it up to temp and see if any coolant leaks out of the tranny connection ports in the rad. I'd drop the pan and check/change the fluid first, but could try the bypass after the pan drop and refill. If you do have coolant in the tranny then a full flush would be an absolute requirement.

"Hey, ya never know til you try." Kurt Russell-Big Trouble in Little China
02blue is offline  
post #5 of 7 Old 05-21-2017, 12:11 PM Thread Starter
olliehopnoodle
Registered User
1982 FSJ Cherokee 
 
Join Date: Sep 2012
Location: mesa
Posts: 1,255
Tried it again today. I wanted to get a good 'hot' reading. Transmission level is fine in hot and it really doesn't appear like there is anything wrong with the fluid.
When cold it would go into gear, I could see the engine RPM drop. I didn't move it. When warmed up it would not feel like it went into gear and the rpms don't drop. Actually the weird thing is the RPM's felt like they slowed a bit when I put the transmission into Neutral.
That's how I checked the fluid. All warmed up and in Neutral. It was pretty much were is was supposed to be. That tells me the pump is probably working. I messed up my finger so no wrench turning for another 6 weeks. I am going to have it towed to a transmission place.

82 Cherokee WT - SOA/SF/agr box/Borgeson ujoint steering shaft/401/performer/holley TA/HEI/BeCool/727/np208/d44(aussie)/amc20(ARB)/BFG 35X12.5/Corbeau Moab Seats/RCI 6point Harness,Hella Aux lights/tuffy console/killer32 slider bars/custom bumpers and roll bar/Alpine head unit/amps/speakers 2002 Liberty Limited Early edition - Basically stock
olliehopnoodle is offline  
post #6 of 7 Old 05-21-2017, 04:47 PM
streetglideok
Registered User
2005 KJ Liberty 
 
Join Date: Jul 2011
Location: Castle Pines
Posts: 3,296
Remove transmission, replace with known new part. Flush or replace cooler and lines. Drive and smile with a much lighter wallet. Problem solved
streetglideok is offline  
post #7 of 7 Old 06-05-2017, 08:06 PM Thread Starter
olliehopnoodle
Registered User
1982 FSJ Cherokee 
 
Join Date: Sep 2012
Location: mesa
Posts: 1,255
We towed it to a reputable local transmission shop. He's busy so it took a few days but when he got to it he determined the spin on filter had come off. He performed a regular transmission service with new filters and fluid. It's working like a champ now.
If my finger wasn't messed up I could have fixed this myself but sometimes you have to pay. I am glad we took it to an honest place.

82 Cherokee WT - SOA/SF/agr box/Borgeson ujoint steering shaft/401/performer/holley TA/HEI/BeCool/727/np208/d44(aussie)/amc20(ARB)/BFG 35X12.5/Corbeau Moab Seats/RCI 6point Harness,Hella Aux lights/tuffy console/killer32 slider bars/custom bumpers and roll bar/Alpine head unit/amps/speakers 2002 Liberty Limited Early edition - Basically stock
olliehopnoodle is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome